[APP][Pro] Eufy Security

@Voltan could, but actually i’m having my own telemetry in the hosted version already. I’m only sharing this docker image for people who want to run it locally. As mentioned in Q13 im not giving support or it, and i wont definitely add features to it. Only if it benefits the cloud version aswell.

The hosted container is the same as the container i shared in Q13. The hosted container should be as lightweight as possible. Keeping track of memory etc will increase the load

I have cameras connected to the Homebase 3. Those cameras are not seen in the app. Will I need to disconnect them from the Homebase 3 or is there a workaround I am missing?

@fisheromega please describe the steps you took.
Did you try to add them via add device?
Its not they will be added automatically, thats not how Homey works

Any issues with the App, or is this Eufy itself?

** EDIT **

A restart of the app fixed it…

Screenshot 2024-02-16 at 21.16.48

1 Like

Hi Martijn,

I did a lot of reading from first to last post :slight_smile:

I just installed my HB3.

I cannot seem to add it to Homey. “No devices found”.

  • installed with primary admin account
  • try to add to homey. Sometimes I get captcha, sometimes not; irrespective I get no-devices-found.

I tried explicitly sharing the device in the Eufy native app. But when I try to share, the HB3 does not show up in the list of shareable devices?

Any clues?


Hey @RogerSt
Can you add some screenshot to make it a bit more clear,?

Edit: do you have cameras connected to your HB3?
If not you cant share it. Then you have to share your house with a resident

Clear, that is it; I will add the camera’s first. I could have known :frowning:
Thanks for the quick response!

1 Like

Hi @martijnpoppen , I think I have got the snapshot self storage on my Synology nas working.
One thing I want to ask is, where are the snapshots stored? I can’t find them anywhere. :woman_shrugging:


@Heula what do you mean? There’s no storage. If you want to store them you have to create a flow to do that. example can be found in Q13

Might be good to read the release post: [APP][Pro] Eufy Security - #5297 by martijnpoppen

Especially this: :point_down: (The self hosted docker service uses the same as the cloud docker service)


I just discovered a bug, that I would appreciate a lot if you can fix when you’ve time.

I want to have an exclamation mark on the Homebase icon when the system is armed (or partial armed), so I have this setting:


Which creates this, as you know:


The problem is that this icon is only set when you do the actual security mode switch. I have scheduled restarts of my Homey, and this morning the icon was gone:


Even though that the arm state still says

I guess you have to look at this option also when the app is started/restarted - right?



When the app restarts the app can’t read the security mode. It will fallback to a default value.
The security mode will be updated based on the notifications from Eufy.

Sometimes there’s a reading in between, but it triggers almost never. So this won’t be a easy fix or a fix at all.

You can send a report after restart, then i can check if there’s data coming in.

EDIT: I was too early, see fix below :wink:

New app update (:green_square: LIVE: 3.25.2):


1: None

1: FIX: issue with wrong security mode on startup (Homebases)

If you find any issues, send a report via the mobile homey app

More - apps - Eufy Security - settings wheel right top - send diagnostic report (put your email in the input field to make it easier)


Thanks as always @martijnpoppen - installed the new version, do you mean it should work now? :blush:

“Away” mode still set in Homey, but no icon :frowning:

@Peter_Kalrsson yep should work.
If not please send me report after restart.

1 Like


Now I only restarted the app, but maybe that is not enough, when I’m thinking about it?

Please let me know if I should restart Homey instead.

Diag no: c8f40514-fb5b-478d-8fba-052effe7fc9f

New app update (:green_square: LIVE: 3.25.3):


1: None

1: FIX: alarm arm mode on restart

If you find any issues, send a report via the mobile homey app

More - apps - Eufy Security - settings wheel right top - send diagnostic report (put your email in the input field to make it easier)


@Peter_Kalrsson should be fixed now :wink:

1 Like

Off course it is :wink:

Verified OK in 3.25.3.

Your are a STAR!


Thanks Martijn, added one extra card to the flow to upload the images to my nas.
Only one strange thing is that when I add the time card so the images will not be overwritten the images are getting weird names.
When only adding a date all goes well.

This card end up in this image name.

With only a date added it looks like this.


@Heula guess you have to check that with the developer of the ftp app

1 Like