[APP][Pro] Eufy Security

Thank you Martijn!

1 Like

I will sell this device. This means, I will not need a fix after all.
Thanks for offering.
Roger

@RogerSt no worries, it’s already fixed since you mentioned it :wink:

1 Like

Hi
Thank you for this. But it seems to be a bug when I enter the amount of seconds. I have to do it many times to get it to work. I tried entering a tag and then removed it and then back and forth. Now it works. So thank you. But so you know, it’s some sort of bug there.

1 Like

@Filip_Hammarstrom better to report that to Athom instead of me, nothing that i can change to the way Homey works

Hey Martijn,

Thanks for the great effort every time! I have a stupid question in the hope you have a small answer. I have bought the eufy security siren at Amazon.com because it is not in stock in te netherlands (not without reason it seems). It is not working and I see UK on the siren and can not figure out why I can’t connect it. Eufy can’t help me either. Do you know why I can’t connect it. Is it a different freq? I know it is not your business but I can’t let it go :frowning:

Thanks again

@Richard_L unfortunately hard to say. Didn’t get hands on this device yet so I don’t know.
you might want to create a new eufy account which is US based and see if that works. US accounts most of the time have more devices available

Hello

Any chance you could provide a container to run on arm?

docker run docker.io/martijnpoppen/com-eufylife-security-snapshot

WARNING: The requested image's platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested

Thanks
Vincent

1 Like

Hey @Voltan
Will have a look!
running on a PI I assume?

@Voltan
done!

If you run the same command again it should work!

edit: make sure to use port mapping

2 Likes

Some thing is wrong…

What I have done:
Installed and running the Synology NAS on 192.168.8.11, with the image on port 3000.
When I access the URL via a browser: OK

On my Homey, I checked the box for snapshot.
Subsequently, I encounter the following error (see screenshot).

Rebooted everything, but unfortunately, the error persists.

Is there an issue with the take a snapshot? If I restart my HP2019 pro it works fine, but after some time, ill get an error sending the picture to my telegram bot.

If I change it to event, it works fine, any known errors?

https://telegram.corbata.nl/?action=sendPhoto&chat_id=62182784&url=https://6273d02f5109040bbb07858e.connect.athom.com/image/48d73377-1381-471d-afa9-5b57b76329f6/image&1707909332.201 reason: Unexpected end of JSON input

I`ve tried with all my cameras, indoor 2k pan & tilt, doorbell 2K, professional E330 and S330, all with the same results.

Any ideas?

@0burner0 so the first thing: you’re in the English topic of Eufy. So please translate your post accordingly.

Please try with the notification of Homey itself.
My guess is a error in telegram.

1 Like

@Anders_Grasmo same a above
Please try with push notification of Homey

My guess is a error with telegram

Unfortunately, even with the notification in the Homey app, it’s not working. I don’t receive an error, but I also don’t get an image.

Today is my first attempt at installing it, so I’m not sure if it worked for me before or if there’s another issue at hand.

@0burner0 can you try the cloud snapshot? As said in Q13 i’m not giving support on self-hosted setups

Can you share your Docker setup ?
Eg. port settings mostly :
obrazek

Also you did open it on your NAS firewall, right ?

1 Like

Came home from work, and it worked!
Did not change anything, but thnx for youre help

1 Like

Hello @martijnpoppen

Thank you very much, it works like a charm with a hosted Docker container running on my ARM system.
By the way, this system is not a Raspberry Pi, but a Freebox Server V7 (a modem and set-top box which can host virtual machines).
I configured the VM to run the container on start.
All looks good.

Congrats for all your awesome contributions!
Vincent

1 Like

Idea: the web page published by the container could contain info, for example…

  • Process start time
  • Process currently used memory
  • Process peak memory usage
  • Number of thumbnails receive since start
  • Size of last thumbnail