[APP][Pro] Eufy Home

Hey @Ron_Meijsen
No I checked it and saw the same. It think it should work.

Hopefully the new devices also work with Tuya API

Hi Martijjn,

the x80 arrived. I installed your test app. I could select the x series.

Tried to get the localId with bluestacks and your apk of the community app. when I clicked the x80 it mentioned this device need a newer app version. and pointed me to the playstore.

then i switched over to your 2nd option and run adb logcat -e ‘tuya.m.my.group.device.list’ but this doesn’t show anything. I did got lines when I run it with adb logcat -e tuya only but no lines with localID.

I also shared the device with another account, no luck
so I am stuck now ;-( anything I can try

ron

Hey @Ron_Meijsen
So you did add the device to Eufy Home already?

I might have some things I can try.
If you want you can share your device with my account and I can try to get the localid

I’ll DM you

New app update (live: 1.2.1 ):

  • FIX: Remove Eufy Robovac X-Series

The Eufy Robovac X8 requires a new version of the Eufy Home app. Therefore it’s not possbible to retrieve the localKey at this moment.

Hopefully there will be work arounds in the near future. :crossed_fingers:

New app update (test: 1.2.2 ):

  • NEW: Add Eufy Robovac X-Series

We found a way to extract the X8 localKey.
If you have a X8 contact me and i’ll help you with getting the keys :smiley:

New app update (test: 1.4.0 ):

  • NEW: Add Eufy Robovac X-Series (1.3.0)
  • NEW: add clean speed picker for X_SERIES (1.4.0)

@Ron_Meijsen Can you check if the clean speed works for you?

Hi

I tested the clean speed and the cards work.

Great job

Thanks

Ron

1 Like

Thanks for checking! :smiley:

New app update (test: 1.5.0 ):

  • NEW: add zone and room to WorkMode for X-Series

@Ron_Meijsen Can you check if the Room and Zone works for you? ‘Spot cleaning’ will trigger ‘Room’

Hello Martijn,

Thank you for all your great work with the Eufy apps. Recently I have bought a Robovac Hybrid X8. I have read this blog so far and I have a question. Can I find the keys with the instructions that I found in the FAQ?

Thanks in Advance.

Hey @pieterzuidgeest ,
Thanks! :smiley:

Unfortunately finding the keys is quite hard. I tried a lot of things with @Ron_Meijsen an after a long search I found a way to do it. But it’s quite hard (extracting the APK etc).

If you want you can share your robovac with me and I’ll try to get the keys for you .

Let me know, then I’ll send the instruction in a DM :slight_smile:

I tested the new app. No more errors. Can start and stop. Change suction power works ok.

Zone cleaning works totally different on x-series. When started zone cleaning on homey no response from robot.

As you can have multiple floors and within floors more rooms. This is very hard to automate. Also becsuse you can select your own names for floors and rooms.

For automation through homey the funtionaity for me is enough.

Thanks Martijn for all you work. Hope the :beer: tasted well.

1 Like

Thanks a lot @Ron_Meijsen !

The :beers: tasted really good! :smiley:

Hello Martijn,

Yes please, if you have the time this will be great.

@martijnpoppen thanks a lot for your really quick response :grin:. I have successfully connected my RoboVac to my Homey.

1 Like

News help pairing my c35 with homey with the new app

Hey @Janderek ,
Can you elaborate on your question?

What part do you need help on? :slight_smile:

U wrote u could help on getting the device and local key
@martijnpoppen

@Janderek ,
Yeah for the X8 I can help. But for the other Robovacs like the C35 I wrote a instruction over here: [APP][Pro] Eufy Home - #4 by martijnpoppen

1 Like

Hi Martijn,

Can you help me to get the device and local key for my X8?