[APP][Pro] Eufy Clean

@duckert [APP] Eufy Home - #4 by martijnpoppen

It will not work :frowning:

Why not?
If there was another way it would be listed in the thread :slight_smile:

An Android emulator is quite easy to manage

@duckert , get an emulator for your OS and you’ll find all the info you need.

Don’t forget to set a static IP for your Robovac, as I did :slight_smile:

1 Like

Hi, im trying these both methods in the first post but the old version of the app doesnt see my RobovacG30 as online. readded it and all.

the firmware is:
wifi: 1.1.51
MCU: 1.3.19

new version of the app (2.6.0) shows the device as online but doenst show the deviceID and or localkey. (also nothing via the adb command)

i have found the DeviceID but missing the Localkey, any clues or hints for me?

Hey @matrover ,
I do have another APK which you can try: https://www.apkmirror.com/apk/anker/eufyhome/eufyhome-2-3-2-release/eufyhome-2-3-2-android-apk-download/download/

In the new app they indeed removed the Localkey/deviceId

With version 2.3.2 you should be able to do it with the ADB debugging

Thnx for your swift reply (as always :))

But didnt work, it still doenst find my vacuum (the ios app and newest android app do), it has an fixed ip. funny thing is that the settingspage of the robot states its connected to my wifi:

made a video:

1 Like

Ah :frowning:
And what if you remove the fixed IP. And try again?
Is your firmware up to date?

Whitout fixed ip, same result. yes latest FW:

saw your dm will reply there

1 Like

And again @martijnpoppen to the rescue!

Fixed it by sharing the robovac with another account, there it appeared online and got the required information! (I can reproduce this working myself)

App works great! Donated a few beers, thanks again!

1 Like

Thanks a lot @matrover.
Always happy to help :smiley:

hi i did all the steps from above but i can’t get my Eufy robot to work,
it states a warning: connection timed out.

could you help me try to fix this >?

kind regards roy

Hey @Roy
Did you try to give the Robovac a Fixed IP?

well @martijnpoppen as far as i know yeas i used the android emulator with the latest version of your eufy app copied the information, evertime it was the same [fixed] ip i used another email to share the device same ip, maybe a bit random but i coupled Alexa to the eufy home account could this be a problems ?

@Roy Hmm in that case it should work.

Can you provide me with a diagnostic report?
I’ll have a look what goes wrong from the Homey app.

You can do that via

More - apps - eufy home - settings wheel right top - send diagnostic report

Hi Martijn,

I have ordered the Eufy X80 hybrid, will arrive tomorrow, it is their this week released latest robot vacuum with mop capability. Would it be possible to support that robovac as well, if I can do anything for you let me know.


Hey @Ron_Meijsen ,
I think it can work as the L70.
I’ll add it to the app :slight_smile:

@martijnpoppen thank you so much. I will test when it is there and get you a good drink :wink:


1 Like

New app update (test: 1.2.0 ):

  • NEW: Add Eufy Robovac X-Series

CC: @Ron_Meijsen added it to the test version of the app.
Will probably go live tomorrow or monday. But you can use the test version to check it out

Hi martijn

Ik gaf aan dat het de x80 hybrid was maar op de site zie ik x8 hybrid. Maak dat iets uit voor de app?

Als het goed is komt die vanavond binnen. Dus van het weekend testen :wink: