[App][Pro] Elgato StreamDeck Integration

I cannot tell. Can you DM me a screenshot of the devices capabilities info from the homey developer dashboard?

1 Like

Working on a fancy new update here :smiley:

I am adding an action flowcard which can push images from Homey droptokens to StreamDeck buttons which have subscribed for it.

The prototype looks promising:
image

Still need to polish a few things though.

PS: This will work for all buttons except for the trigger and push button ones. Including SD+ dials

1 Like

Okay. This took a day or two more due to app clearance stuff, but the update is here!

This update adds support for window coverings and custom images sent by Homey! Enjoy!

2 Likes

Hey @Shakesbeard Looks like a great plugin! But somehow i can’t install this app on my homey pro 2023, I just get the error message „Elgato Streamdeck integration is not compatible with this homey“. Everything is up to date - any Tipps how I can install the app on my homey?

Hey Inter,
Well, this is strange. It is compatible and should just install really. Maybe a hiccup on the Athom store.
Just try it again tomorrow and double check you selected the correct Homey.
If it still doesn’t work, I can have a look at it next week.

Hey, thanks for answering so quickly! I‘ve actually tried to install it a few times since I bought the homey in September 2023 because I really would like to use your plugin, but I always get the same error message (attached a screenshot - but in German)

The app isn’t compatible with Homey (cloud) you selected in the screenshot. You need to select a Homey Pro.

I also have several roller shutters, also in my workplace and it would be great to be able to set them to a certain position with Streamdeck I use Somfy and they only show up as devices in dials but I can not use them. Would it be possible to add shutters?

hmm… if they expose a position capability they should actually work. Can you DM me the excerpt of the device details from your Homey Developer dashboard for one of them?

Is there any documentation on how to set a button image from one sent by the Homey ?

hmm… don’t think I documented that really but it is straight forward.
You set up a button and give it a tag/name for the image like this
image
Then you need a flow to sent any image available in Homey to the button like this:
image
The image is given as image drop token to the flowcard.
Effectively the SD receives the URL of the image from Homey.

I asked before giving it a go. It was actually quite Intuitive. I was able to push a snapshot from my RING doorbell on doorbell press. Pretty cool!

What I cannot seem to get working is the trigger feature when using Display Data [+ Trigger]

Here is what i am attempting to do

Hello, just got my stream deck mini. I tested your app directly but sadly I’m encountering a weird issue that no one seems to get until now in the topic.
App and pluggins are installed, on the stream deck I can add “Toggle a Device On / Off” or even “Display Logic Variable”, for the config I added either my IP or the .homey.homeylocal.com + my access key.
Both are able to retreive the device, data source but then the logic variable stay black, no value are showed. If I click on the on/off nothing happen. I have a yellow warning mark as soon as I push both options.

Port 4693 is open on my laptop (Windows). I tried to reboot laptop and stream deck but no luck.

This is simple too.
Homey:


StreamDeck:
image

That is indeed a little strange. Got to your Homey and restart the StreamDeck Integration App. Maybe something was off when initializing the Homey api.
If this does not resolve the problem we will have a closer look at it.

I forgot to mention that I also tried that. Help will be appreciated :slightly_smiling_face:
Is it possible to provide you some sort of logs ?

hmm… weird. You can try triggering something from the SD and then submit an app diag report through the homey app in the apps menu. Can at least check what Homey says. But it does sound like a connection issue actually.

I confirm the issue is related to my laptop. On another one it is working perfectly.

Since a week or so im having the exact same issue until i restart the app. I did the same thing yesterday though. A restart seems to be only a temporary fix.