[APP][Pro] < Ecovacs Deebot >

My Ecovacs T8 is hidden under a cabinet. Filling up the water is kind of a hassle since I need to remove it from underneath the cabinet. Is there a way to trigger it to go to a specific location? That way I can make a flow to go to my kitchen so it’s easier to change the water.

Nice idea, a parking mode :slight_smile: Not sure if it’s possible, I’ll have a look at it this weekend.

1 Like

I published a new test version that is currently in review. The app now has an option to ‘park’ the Deebot.

You can pause Deebot when it’s at the desired ‘parking spot’ (just start a spot cleaning session) and then press the button “Save parking spot”

The current location will be saved, and when needed you can press the button “Park” (also available with an action flowcard) to let the Deebot navigate itself to the parking spot.

2 Likes

I have now two deebots, a X1 and a t9aivd.
But it looks that the two are not really seen as two in the app. I can chose both separatly, but when i send a comand to one, it is done on the other. Not for everything, but when a comand is executed on the wrong, it alwasys is.
I now tryd to install the old deprecated Ecovacs app and manage one whit that, that works.

I’m on aholyday now, when I get baack I’ll see if I can figure out what is wrong.

I have a deebot X1 Omni. Is there a way you could include the video manager options? Such as starting a recording, making photo’s or start a patrol?

Would be great to be able to use the vacuum as an additional source of surveillance/security once an alarm or something goes off.

And if extra it would be cool if you could add the station actions such as cleaning pads, heating pads, empty dust bin.

If you need info/data from my device, just let me know and I will try to help!

Would there be a possibility to add mop and vacuum, vacuum, mop, vacuum then mop, options as Then cards?

Just got a t20 omni, and I want it to mop once per day, but if we leave the house again, it doesn’t need to mop, only vacuum. Right now I don’t see an option to set it as only vacuum. Even of the mopping attachment is on, it can vacuum only

1 Like

Is this app still working as I get ‘Invalid Credentials’ when trying to set it up and I know the credentials are correct.

Thanks

You could at least reveal the secret of which model you own.

Also you can give it a go with the earlier app version by Glenn:

I own a X1 Omni, As I cannot even login I didn’t think it would matter which model I had.

I have tried the older version and get the same issue.

1 Like

Thanks. I only can say double check on leading/trailing hidden white spaces, and capital letters.
What’s the error message by the way?

It just says ‘The provided credentials are not valid.’

Thanks for the suggestions but it all appears ok. I’ve even changed my password as it had a few special characters in but that didn’t work either.

I’ll keep trying but thanks for the help

1 Like

Hi Daniel,

I forgot about it, but I just tried to add my vac; I could login and Bob was found and added within a few seconds… (Bob here is a classic Deebot Slim 2 - DA5G.11)
I’m not sure your issue is an app issue, sorry.

Last thing I can think of, is your vac online when you try to add it to Homey? I think that is important here.

I’m having the same issue. tried changing the password that made no difference. I have a T20 but I think it’s a moot point as I can’t even login.

my log for what it’s worth

[log] 2023-10-20 20:11:34 [Libraries] 2023-10-20T20:11:34.614Z [log] [Deebot] Settings changed: autorefresh set to true
[log] 2023-10-20 20:11:32 [Libraries] 2023-10-20T20:11:32.814Z [log] [Deebot] Settings changed: verbose set to true
[log] 2023-10-20 20:11:32 [Libraries] 2023-10-20T20:11:32.451Z [log] [Deebot] Settings changed: libdebug set to true
[log] 2023-10-20 20:11:31 [Libraries] 2023-10-20T20:11:31.834Z [log] [Deebot] Settings changed: appdebug set to true
[err] 2023-10-20 20:00:45 [Libraries] 2023-10-20T20:00:45.012Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[err] 2023-10-20 20:00:29 [Libraries] 2023-10-20T20:00:29.862Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[err] 2023-10-20 19:58:37 [Libraries] 2023-10-20T19:58:37.983Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[err] 2023-10-20 19:58:13 [Libraries] 2023-10-20T19:58:13.317Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[err] 2023-10-20 19:57:45 [Libraries] 2023-10-20T19:57:45.851Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[err] 2023-10-20 19:57:31 [Libraries] 2023-10-20T19:57:31.197Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[err] 2023-10-20 19:57:17 [Libraries] 2023-10-20T19:57:17.540Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[err] 2023-10-20 19:57:09 [Libraries] 2023-10-20T19:57:09.229Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[err] 2023-10-20 19:17:41 [Libraries] 2023-10-20T19:17:41.034Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[err] 2023-10-20 19:17:28 [Libraries] 2023-10-20T19:17:28.758Z [err] [ManagerDrivers] [Driver:Deebot] Failure in connecting!
[log] 2023-10-20 19:16:11 [Libraries] 2023-10-20T19:16:11.728Z [log] [ManagerDrivers] [Driver:Deebot] appdebug: false
[log] 2023-10-20 19:16:11 [Libraries] 2023-10-20T19:16:11.727Z [log] [ManagerDrivers] [Driver:Deebot] Driver Vacuum has been initialized
[log] 2023-10-20 19:16:11 [Libraries] 2023-10-20T19:16:11.191Z [log] [Deebot] Ecovacs Deebot is started
[log] 2023-10-20 19:16:11 [Libraries] 2023-10-20T19:16:11.171Z [log] [Deebot] nl.onzewifi.deebott9 V1.4.5 is running...

It seems not to be able to connect to your vac

When it’s docked, pull the power cord for a few seconds.
The vac should be online again after a short while.
Then try to login again.

My logs show this error

[log] 2023-10-23 18:02:18 error error: ‘Error: getaddrinfo ENOTFOUND gl-gb-api.ecovacs.com

I tried a factory reset on the Deebot but that didn’t resolve it so I gave up.

For what it’s worth I am fairly sure this is location based .

Looking at the source code it grabs the locale details from ipinfo which sets it to gb but the Ecovac api actually wants it to be set as uk rather than gb

http://gl-gb-api.ecovacs.com/ - Fails
http://gl-uk-api.ecovacs.com/ - Successful

I think if you changed the location of your Homey to US so that it called the US api it would probably resolve the issue but I am not sure what else this could break so I wouldn’t recommend it.

We just need to hope that the developer sees these posts and releases an update to resolve the issue.

Hello, I am really happy to that there is a Ecovacs app for Homey as I have two Deebots. One for the ground and one for the upper floor. I found that if I want to “start cleaning all rooms” through a flow (my test flow is attached) for the ground floor, the Deebot on the upper floor starts to operate. If I start the Deboot on the grounf floor by navigating to the device and clicking “Auto clean”, the Deebot in the main floor starts to operate. That is also happening for other actions e.g., empty the dustbin. The Deebot on the upper floor is reacting instead of the one on the ground floor. Any ideas?

Not sure what is happening, I only have one Deebot, so can’t tes it myself. Could you please reproduce the error, and then send me a diagnostics report?