[APP][Pro&Cloud] Shelly

Thanks for the quick reply. But I have no clue why it is not connecting to the cloud service…


Do I need to do a port forwarding? I don’t think so.

After hours of back and forth, I finally got it to work…

Here’s what I did:

  • Connected Shelly to my phone as a personal hotspot. This allowed the cloud connection to work.
  • Then, I performed the firmware update.
  • Switched back to my regular WiFi.
  • Restarted the router.

Now it works perfectly!

Hopefully, this helps anyone else facing the same problem.

Too soon to celebrate. After a short time, the cloud connection drops again, and the WebSocket stops working. However, I can still control the Shelly device flawlessly, both from Homey and the Web UI. The only issue is that the status doesn’t sync promptly with Homey when I switch it from the Web UI.

I suspect it’s my Netgear Orbi Mesh WiFi. Something about it doesn’t sit well with the Shelly…

If polling works but websocket and cloud don’t you should be looking at outbound traffic from the device to LAN and WLAN. Perhaps a misconfigured firewall.


All of my Shelly Devices have been disconnected, also they are still connected and working within the Shelly App. All ways, disconnecting, new installation of Shelly Homeyapp, did not work. Homey is not able to find and conbect any of my Shelly devices.

Read the first post in this topic to troubleshoot your issue.

Would it possible to develop Shelly H&T And cards (so that we can check temperature or humidity in And conditions of flows) ? Same as what is done with Tado Smart radiator cards for instance.
Thank you.

Hi MG,

You’re supposed to use Logic cards as AND cards, as explained to you by Dirk 13h ago

See this thread. TL;DR: using Logic is a paid feature for Homey Cloud so can’t be used.

I did not find a hint in your first post.
The devices had been connected to Homey and did work quite well. (static IP)
The Shellys have been as a device with the correct IP in the properties, but it was shown, that they are not available, but are still available within the Shelly App on my mobile device.
The disconnection happend during my holiday, at time I did not make any changes to the system. They just have been disconnected and and it is not possible to connect the again. Homey is not able to detect they are just invisible for homey.

Then you probably didnt read it very well. Do you wanna make a bet for a donation of EUR 5,- to the plastic soap foundation that the answer is in the first post. You could send me the diagnostic report from the app settings and I’ll see if I can prove that.

Homey will not show already added devices. If they are new or removed and still not visible it’s an mDNS issue.

Thanks a lot for helping me with my issue. :pray: :+1:

It seems that there were multiple problems.

The reason the WebSockets were not working seems to be a misconfigured WiFi connection on Homey, running parallel to a cable connection. That appeared to be the main issue. Since I corrected that, everything has been working smoothly, including the other Shellys.

All my shelly devices ar not available in homey anymore. The firmware on all devices is up to date.
Is there a way to fix this? I Can still reach them from the shelly app.

But since yesterday nothing works in homey anymore.

After reading the first post again. Do I need to repair all the devices again?

Restart the app (or reinstall it from the app store) or your Homey Cloud instance. It seems Homey Cloud or Shelly Cloud had an issue yesterday which was unrecoverable from the app.

This means I have to re add all the devices right?


Right after install the app crashes directly again…

I have the same problem. The application does not work

Same. Removed the app and reinstalled it (lost all my shelly devices) and it keeps crashing.

Please report it to Athom. There is an issue with Homey Cloud. You can use this error as reference.

request to http://cloud-shelly-3-29-5-2.cloud-shelly-3-29-5.apps.svc.cluster.local/api/app failed, reason: getaddrinfo ENOTFOUND cloud-shelly-3-29-5-2.cloud-shelly-3-29-5.apps.svc.cluster.local

1 Like