[APP][Pro] Broadlink App

I just send a log to you
Thank you

1 Like

Martin, for your RM4 Mini I see :

05:20:30 [Broadlink] **>onPair.start_discover: {"address":"192.168.1.196"} 
05:20:30 [Broadlink] **>onPair.localAddress: 192.168.1.158 
05:20:30 [Broadlink] ==> Communicate.sendto - create socket 
05:20:30 [Broadlink] ==> Communicate.sendto - send packet to 192.168.1.196:80. Data: 0,0,0,0,0,0,0,0,0,0,0,0,232,7,20,5,24,7,9,6,0,0,0,0,192,168,1,158,200,173,0,0,103,195,0,0,0,0,6,0,0,0,0,0,0,0,0,0 
05:20:35 [Broadlink] **> dgramSocket timeout 
05:20:35 [Broadlink] **>onPair.rejected: Error: Timeout while sending message to device: device did not respond in time 
05:20:43 [Broadlink] disconnect 

which means, that your RM4 Mini did not respond to pairing attempt at all.

May I please ask you, if possible :

  • doublecheck you used right IP address - 192.168.1.196 (eg. you can try to ping it or check the Broadlink app)
  • ensure your Homey and Broadlink is within the same VLAN and on the same Wifi SSID (just to be sure)
  • check if you are on firmware version v62092 and update eventually
  • your device must be added into Broadlink app prior attempting to pair it in Homey , also I found interesting comment on IoBroker implementation for Broadlink :
Note on new RM4/LB1 devices
Several new Broadlink-Devices support a new Broadlink-Cloud protocol which is automatically selected when you use the newer broadlink apps to bring in the device into your wifi network. THis new broadlink protocol is not compatible with the broadlink2-Adapter and you cannot use devices using this new protocol.
To avoid this problem bring the device into the network using older Broadlink apps like e smart home or e-control and make sure your phone is on the same 2.4GHz wifi network which you want to bring it in!

(e-control app - https://play.google.com/store/apps/details?id=com.broadlink.rmt - I believe you would need to reset your device however, add it into e-control, first (temporarily), to the Broadlink app 2nd)

  • you must not have device locked (you did confirm you unlock it)

My RM4 MIni I purchased just week ago is working fine. I added it directly to the Broadlink app (exactly to test possible problem with new protocol but it wasn’t the case), having latest firmware v62092 and device is working fine. So I hope we identify the culprit.

@Lipas , if you can please :

  • enable debug in the app settings of Homey Broadlink app
  • restart the Broadlink app
  • remove previously added RM4 Pro
  • add it back and sent me diag. report
  • try to learn signal and again sent me diag. report

My firmware is not v62092 it is v52079. My broadlink app says that my firmware is up to date! Do you know where I can find v62092?
/Martin

Frankly, older version should not really be an issue, it’s rather vice-versa :wink: Has this integration ever worked for you, or you are attempting it first time on Home 2023 ?

But if you are 100% sure you are on RM4 MIni / v52079, and online update do not offer you anything, you can try to reset your device and if it will not help, probably try to contact Broadlink support, if they can provide you with URL for manual update. There are links for v62092 but it’s for RM4 Pro unfortunately and I don’t think they are compatible.

This is the first attempt to connect RM4 Mini to Homey. I have reset the Mini but that did not help. So now I am waiting for a firmware URL from Broadlink to update. I let you know when it is done.
Thanks
Martin

1 Like

Many kudo’s for taking up this app, @Sharkys!
Please let me know how I can buy you a beer… :wink: (I suppose the "donate"link on the app page doesn’t lead to you?)

I have a RM3 mini, already paired to the Broadlink app.

Adding to the e-control app wasn’t possible unfortunately. The app isn’t compatible with my Samsung S24 (Android 14) anymore. Fortunately I could still install the e-control app on my iPad (currrent iOS version), but it doesn’t let me sign-in with my current Broadlink credentials, do a password reset or create a new account…
I now learn that this doesn’t have to be used for the RM3 mini, but perhaps good to know. :wink:

When opening the Homey (HP23, latest stable firmware) app settings I get the following error:

I could also not add the RM3 mini to the Homey app.
After entering the IP-address it keeps saying it is discovering the device.

The settings error seems fixed though, possible after enabling/disabling log mode(?).
After that, adding was possible.
Now configuring the device in Homey…

RM4 Pro added
Log1: 993164e4-2943-4e55-910d-a541241e5e7e

Learning command
Log2: ddd70b92-b0ba-4520-a560-7f8f8c3c2d85

1 Like

For the test version it does but waiting for release to the prod version till (if) we smash the bugs :slight_smile: So I would wait until all is working.

I believe that might be required only for RM4 and later and only in case previous Broadlink app enabled newer protocol, RM3 Mini should work out of the box. Just FYI, my RM3 Mini is about 4 years old, RM4 Mini has been purchased recently but I added both directly in the new Broadlink app and didn’t have to do anything later about that.

This is the Compatibility mode not the debug - but enabling debug will save all the data, so that’s why error will dissappear later - anyway, thanks to reporting, will be fixed in new test release (in which I will also enable for now debug for all users and later on, after I will get necessary data, that settings will again be reflected accordingly)

1 Like
09:27:02 [unknown (Type: 0x4e2a)] onInit - logData: {
  ipAddress: '192.168.0.170',
  key: '',
  deviceType: '0x4e2a',
  deviceName: 'unknown',
  typeName: '4E2A'
}

Seems you have yet unrecognized Broadlink with ID 0x4E2A - also the name is not resolved and based on this discussion, it’s AC Unit ?

Are you sure your IP address is correct ?

1 Like

What a mistake. Sorry for making troubles. I’m making two things at one time :joy:

Seems, that RM4 Pro is working now. Learning and sending commands it’s working fine.

1 Like

Great ! :slight_smile:

Even in that case, please send diag…thank you

No problem. Although even your effort and the will to take up this app is worth the donation.
Thanks for the quick reply!

1 Like

Hey! My RM4 Pro IR learning doesnt work - any idea?

d2bae93e-88b6-4425-8894-5c7857178990

Br Mario

Just tested it today, Sharkys, on a Pro 2019.
Works like a charm with a RM3 mini red bean version.
Kudos for making it much more user friendly!

1 Like

Anyone here with BroadLink SP3s device, who can provide the debug right after app start and then after 2min, or ideally is OKay with adding me as Home member ? (note on the security and privacy risk, despite of my reputation here on the forum, it’s my duty to warn you) . The power readings are still wrong unfortunately …

@Henk_Renting I really appreciate, thank you !

@Lipas , still some debug logs to see it’s working as should, would be great, as others with RM4 Pro reports it’s not working for them (eg. Jgalpine80).

@Fellaz , I sent you PM with instructions

@Peter_Kawa , fantastic, glad to hear ! :wink:

1 Like

RM4Pro: downgrading firmware to v62092 did the trick. BIG SHOUTOUT to @Sharkys

1 Like

FYI, current “state of operations” …

Working / confirmed working or also fixed : :+1:

  • RM3 Mini + Red Bean + RM4 Mini confirmed working
  • RM4 Pro confirmed working (must have firmware v62092)
  • SP3S - fixed power reporting (missing polling) (SP2/SP1 shall be working as well)
  • SP2 / SP3 power measurement reporting not in line with reporting from official app

Not working / issues :o:

Unknown / no feedback / no log :interrobang:

  • you tell me

Note on :
!!! RM4 Pro !!! users could update/downgrade to 62092 version in case the Homey integration do not work - http://124.71.130.238/RMBL4-62092-8720-BL-FC-3389.upd.bin based on Reddit - Dive into anything - eg. there are comments that 62093 version broke the other integration for some users, it might be similar issue for some of you trying to add RM4 Pro (so far confirmed by Fellaz user).

Please note this action might be potentially risky, so don’t hold me accountable.

Do not forget, you must have device UNlocked !

Also if it still doesn’t work, it might help to reset your RMx device, add it to Broadlink app and then to Homey.

Version 3.1.26 — Fixed SP2 + SP3s power readings + logging optimisation

Hi Sharkys, thank you very much for doing this!! I had it working on my Homey2019 and was very unhappy it did not work on HP2023…

I have a RM4 PRo, which works fine from the Broadlink app. The firmware seems quite old (V52079), but the broadlink app says it is up to date. I tried the link provided in the post above with the correct firmware but I get an error when updating halfway (tried it form iphone and android, same result).

I can add the RM4 Pro to Homey without problems. Unfortunately, I only see the “learn IR” button, and no " learn RF" button.

Anyone has any ideas?

Hi Vincent,
if the integration works out of box, no need to upgrade-downgrade firmware.

This is not implemented yet, I was actually waiting if someone will come-up with that for RM4 Pro. Unfortunately remote testing only would be more complicated, good news is that I purchased RM4 Pro myself and it’s on the way, then I assume will release update.