[APP][Pro] Bluesound - Multi-room Music. The Hi-Res Way

The card is a list of favorites. Personally I have only 4. When you click it an api cmd is sent to play that preset. There is also a cmd to get the list.

This is how it looks like in the BluOS app: https://drive.google.com/file/d/1iRT_wfPaDLOwxavyrzahzn1Y2cpbIl9e/view?usp=drivesdk

As far as I can tell this is not possible. I can not add a custom capability that dynamically adds it’s options. I have asked on the developer channel on Slack to get confirmation.

[EDIT] Nope, not possible.

1 Like

Maybe one day

Did you figure it out why we see these time-outs?

At the moment it’s working. I had these issues once since I’ve reported it, but currently it’s working. If I see issues again I’ll run the debug app.

Could it be a difference between debug-version and production?

If I open the mobile app, I can see the device going offline continuously.

You should always make sure you have the latest production versionb of the Homey app. Debug versions are not maintained with updates.

One of my 4 bluesound devices now installs fine but homey then immediately says it’s unreachable. The other 3 devices work fine. I’ve restarted the app, the Bluesound devices and my WiFi. I have all the latest updates installed.

I don’t understand :-/

Is it continuously no response ? Or sometimes.

You could go visit the IP in your browser. It should open up a page

Lately my bluesound devices are 100% of the time offline in Homey.

Today I had some time to investigate, when I add a device and use test connection it works. When the device gets added it’s directly unreachable.

Both devices are connected via cable.

I did p2p

Not a clue, the Homey app has not changed. So either Bluesound changed their (undocumented) API or something in your setup has changed. Since none of the others using this app seem to have this issue I’m guessing it’s something in your setup. Does the device have a static IP and did you try running the app from the command line to see if that gives any more information?

I see you submitted a log. I see two things here, it’s not able to parse a specific response. I can look into that if you can send me the result from http://<<yourip>>:<<yourport>>/Status. But I also see the device goes offline so perhaps at the same time and is unreachable. Perhaps the response is malformed due to the device going offline. You should like into any connection issues as well.

2019-09-29 15:46:05 [log] [ManagerDrivers] [bluesound] [0] TypeError: Cannot read property '0' of undefined
    at /lib/util.js:70:43
    at Parser.<anonymous> (/node_modules/xml2js/lib/parser.js:303:18)
    at emitOne (events.js:116:13)
    at Parser.emit (events.js:211:7)
    at SAXParser.onclosetag (/node_modules/xml2js/lib/parser.js:261:26)
    at emit (/node_modules/sax/lib/sax.js:624:35)
    at emitNode (/node_modules/sax/lib/sax.js:629:5)
    at closeTag (/node_modules/sax/lib/sax.js:889:7)
    at SAXParser.write (/node_modules/sax/lib/sax.js:1436:13)
    at Parser.exports.Parser.Parser.parseString (/node_modules/xml2js/lib/parser.js:322:31)
2019-09-29 15:46:07 [log] [ManagerDrivers] [bluesound] [1] { FetchError: request to failed, reason: connect EHOSTUNREACH
    at ClientRequest.<anonymous> (/node_modules/node-fetch/lib/index.js:1345:11)
    at emitOne (events.js:116:13)
    at ClientRequest.emit (events.js:211:7)
    at Socket.socketErrorListener (_http_client.js:401:9)
    at emitOne (events.js:116:13)
    at Socket.emit (events.js:211:7)
    at emitErrorNT (internal/streams/destroy.js:66:8)
    at _combinedTickCallback (internal/process/next_tick.js:139:11)
    at process._tickCallback (internal/process/next_tick.js:181:9)
  message: 'request to failed, reason: connect EHOSTUNREACH',
  type: 'system',
  errno: 'EHOSTUNREACH',
  code: 'EHOSTUNREACH' }
2019-09-29 15:47:08 [log] [ManagerDrivers] [bluesound] [0] Device is not reachable, pinging every 63 seconds to see if it comes online again.

Hi @Phuturist,

My Homey died last night. So I won’t be able to test it. I didn’t change anything lately in my set-up. About 2 months ago I made it better by connecting one of the devices via cable and no longer using wifi. I do update sometimes Bluesound. But up until this moment that never caused anything.

The device is for sure online, I had my PC open and the official buesound app (that use the same API). And I can ping it, i can sent any command. Test connection gives a 100% online respons, but when it was added it was 100% offline.

The respons is this btw:

Can't Slow Down Lionel Richie true 249 Tidal:77598434 /Artwork?service=Tidal&songid=Tidal%3A77598434 0 0 1 Hello 1974 0 2 Tidal /Sources/images/TidalIcon.png 1 5 249 stop 37 Hello Lionel Richie Can't Slow Down 248 38 0

but as i mentioned. My homey is dead. My Homey died ;( So i’m crying at the moment and i will not be doing any testing for now :frowning:

1.3.4 - 2019-12-11

Fixed issue with relative volume action card.

1 Like

Is the app supposed to work with Bluesound PULSE mini?
Trying to find out where I gp wrong.
B Rgds. Martin

@Phuturist. Is the powernode 2I supported Jelger? Thanks in advance.

I would not know. I built this app purely based on documentation, I do not own a Bluesound device myself. If that device uses the same API as other Bluesound devices you will be fine. Either try it yourself or find someone who has already tried it.

Thanks. Just interested in the device. Before i buy it, it would be nice to know😜. Anyone else?

You could ask on the Bluesound forum but I’m 90% sure it’s the same api and it will work

Thnx. I also found in the old forum that @Its_Me owns a node2, so i guess it will work with the powernode also.

@Phuturist my NAD still times out sometimes, same issue since the start. You always suggested me to do a CLI-install of the app in order to debug.

Well, i lost motivation to play with my Homey when it died. But now i’m slowly recovering and getting to the point that i should investigate this issue.

Before I find out how-to CLI install an app on a Homey. I was wondering, can’t you submit your app to the new Homey Community Store so that I can install it with a single click? Is it then debug-able? Or should I still go for the CLI-way.

And if I do install it that way, can i run both apps next to each other? Or should i remove the official one. And how can I do debugging in order to find out what’s the issue?