[APP] Denon Heos app form @nlrb [Not in app store]

Hi fellow community members,

I wanted to point out the fabulous alternative Denon Heos app from @nlrb
When i had some throuble (missing features and lost connections) with the Athom Heos app, i went searching for alternatives, @nlrb pointed me to his app on GitHub: https://github.com/nlrb/com.soundunited.heos

For those of u who aren’t familiar with installing an GitHub (version) of an homey app, follow this guide: https://community.homey.app/t/how-to-cli-install-method/

In my experience it’s more stable than the Athom app, and it has more features, i’ve created this post to point fellow community members and Heos users to this great app (with agreement of @nlrb, and many thanks for his effort!).

D&M Heos app

Control your Denon/Marantz Heos devices with Homey.

This app supports all Heos devices (all with device specific images).

The following triggers can be used:

  • Playback starts
  • Playback pauses
  • Playback stops
  • Now playing changes
  • Volume changes
  • Artist changes
  • Album changes
  • Track changes
  • Now playing changes

The following conditions are implemented:

  • is/is not playing

The following actions are implemented:

  • Play
  • Pause
  • Toggle play/pause
  • Previous track
  • Next track
  • Set volume
  • Mute
  • Unmute
  • Shuffle on
  • Shuffle off
  • Repeat (off, repeat track, playlist)
  • Play Heos favorite
  • Play URL
  • Select input
  • Turn on/off (For receivers only)

:uk: English is supported at this time

Change log


  • Turn on/off receivers added
  • fixed no response handling
  • Workaround for mobile app: cannot handle empty image element
  • Workaround implemented for changed Homey CLI behaviour


  • Added new icons and input select


  • Added play URL

This thread will be updated if there are any changes or updates.


@matrover Hi,

Big Big thanks, the athom app crashed every time for me. I will test the app from @nlrb, thanks again

I just installed the app, but im not able to sign in. I enter my credentials, but the button just says “log out”.
Status says “logged out”.

Any ideas?

The “save settings” button is logging you in. so try to play a favorite via an flow card, see if it works.

Nice let me know if this app works better for you!
All the thanks go to @nlrb, im just the messenger :wink:

Thanks, Will try this!

Is it possible to play on grouped speakers? (Something I never could with the other app.)

Hi, installed the app, it crashes over and over.
Stopped the Marantz app, no succes
Removed Marantz app, no succes
Restart homey, no succes
Re-install Heos app, no succes

22nd app on my homey, you think thats too much?

Yes its possible to contol grouped speakers, e.g. The pause command for one speaker in an group wil pause the whole group.

Making/adding and removing of groups is not yet supported.

1 Like

Could you send the debug log? (Where you typed athom app install, type athom app run instead, the debug log wil show)

Which heos device are you trying to operate?

Tried to operate Marantz SR6012

Ok, is there an denon-avr folder in your node_modules folder?

Can’t find that folder

That is the problem then, seems like you didnt download the whole repository from github

I don’t get it.

I did download the ZIP from github, https://github.com/nlrb/com.soundunited.heos
The denon-avr folder is in the ZIP

So, how could I miss that?

Dont know mate, is it working now?

No, what was it that you thought it should be working?

I dont know, could you try all the steps again? the error just states that is cant find it.

thanks for the app! I think it’s really great.
I just installed it, no errors at all in CLI.
But when I open my Homey app the first thing I see on my timeline is:
the app D&M Heos has stopped working.

When I restart the app it says: Crashed during loading in a red window on top of the app.

I also can’t open config

What is wrong? Help is welcome :slight_smile:

Windows defender started freaking out trying to download the latest version from github (a false positive, as there is nothing that can have the trojan is in there), this might be the cause of the module not being there after downloading

thanks for your quick reply. My windows defender didn’t gave a problem, but still I tried again. Make sure everything is right. Still same problem… what could it be? :frowning: