[APP] Denon Heos app form @nlrb [Not in app store]

Hi @zee-eend could you try running the app from the cli (command: athom app run) this way the debug log will show, maybe that gives us an hint

Hi @matrover,

Thanks for the help. I got exactly the same error as @Undutchable . When I look at the node_modules folder there is folder denon-avr and also denon-heos. So that seems to be ok?

Hi @zee-eend & @Undutchable, ive tried it on an windows 10 computer (fresh install) with windows defender and no problems at all.

im kinda out of options to be honest, but try this:

  1. could you try as an admin (run comnmand prompt as admin)
  2. or try running another app (example)

@matrover Hi,
I can confirm that, no problem here to install.

1 Like

I tried your first option, no luck.
The second one I will have to test…

But strange…

I tried to install a random app via cli: in this case Qubino, without any problem

So I have no idea what the problem could be :frowning:

I seeing the exact same issue as @Undutchable, also when running as root, other apps don’t crash (option 2). Is it a requirement to have an operational installation of the Athom Heos app - my heos app can’t find any heos devices…

I’ve been looking at the problem, but since everything is complete (like the node heos-avr etc.) It must be an app problem. So @matrover: U tried to install it when downloading the app from github recently (anywhere between now and the last update?)

Because we all have the same error now, and the error code looks app related, it has to be app related (I think)

Thnx for testing

Ive tried it with 1.1.3 of the app and 3.2.1 of homey (normal late 2016)
I will try again tomorrow just to be sure

1 Like

Hello, I have a Marantz NR1508 receiver wich has Heos. I’m able to control it using the marantz app, but I like to give this app a try. I have installed the app, but when I look for devices it does not find my receiver. This receiver should be compatible right? Or am I missing something…

I’ll stick to the Marantz app, it’s working and I’m not so into special installation instructions. Thats for the IT-guys and girls among us.

Meanwhile keep tracking for the development of this app, but with one eye.
Thank you everybody who participated to get it working.

@Marcel_Visser by the looks of it, it should work. Does it work with the normal denon app from the app store? And could you try to run the app so the debug log shows: “athom app run” instead of athom app install

i found out why the app won’t install via CLI.

The lastest versions of CLI doesn’t send any node modules to Homey that aren’t in the package.json (a file that is currently not in the repository at all).
Let me contact Ramon with a PR with the added package files that are missing, that will fix the modules not being send to Homey.
If you can’t wait, you can also use my repository until Ramon accepts it, or adds the files himself.
edit: Already merged.

1 Like

Great @Caseda thanks!

@zee-eend, @Undutchable, @CasperD could you test this?

Great! Thanks @Caseda and @Undutchable. I will test it after work today!!

It works now! Thanks again :pray:

Only getting this after 2 times trying to add device:

─────────────── Logging stdout & stderr ───────────────
2020-02-08 23:04:53 [log] [HeosApp] D&M Heos is running…
2020-02-08 23:05:12 [log] [ManagerDrivers] [heos] Heos speaker pairing has started…
2020-02-08 23:05:36 [log] [ManagerDrivers] [heos] Heos speaker pairing has started…

EDIT: The original homey app is also not working for me… BTW: My receiver is still connected using the marantz app on homey… Wil this be the problem? Maybe its only able to connect to 1 device?

Tested :slight_smile:
All works well, no issues or suspicious logs.
Bug fixed :+1:

@Marcel_Visser: can you control Heos with the Heos mobile app? If so, this app should also work.

As receivers can be turned off completely (in contrast to real Heos speakers that are always on), make sure the receiver is on and the network stack stays active when it is in standby.

The Maranz app will use another protocol to control the receiver (connects to telnet port 23, compared to telnet port 1255 for Heos). So no problem to use both apps at the same time.

To test if you can control your Heos receiver, you can use telnet <receiver_ip> 1255 and when connected enter e.g. heos://player/get_players.

1 Like

Not a bug IMHO. Workaround implemented for changed Homey CLI behaviour :wink:

Thanks. Wil try tomorrow when I’m back home. The heos app on my phone and tablet works fine.

Last try, no succes.

"Homey De app D&M HEos is gestopt met werken.

When trying configuring app for Heos account settings message:

Error: not_found