[APP][PRO] Aseko Pool dosing systems

Hi Martin,

did you somehow manage to capture the possibility of when the timer is set? Or it would be possible to test for inflow to the probes. When the filtration is turned off, there is a “no flow warning” and at that moment all water values are unusable. as soon as the “no flow warning” disappears, the values can be read. Then it would be enough to test “no flow warning” with ASEKO probes in “AND” in flow-homey

I have added your request for a condition card to test if filtration is active. I could see if it is possible to add a trigger for it as well, but that is not so easy I noticed.

The next release will give you trigger for timeline warning, you can test for no flow then …

you can test it now…

everything seems to be OK. does the test in the “AND” test the flow to the probes or the timer setting? that means it doesn’t really work (no flow to the probes) - alarm option
or planned (timer setting)?

The AND for filtration looks at the defined timer settings and if the current time is within those settings.

The trigger for timeline problems gives the reason in the tag called timeline message, if you compare that in the next AND step to ‘There is no flow to the probes.’ with ‘logic’ you should have all the needed components to act.

You’re probably right, but it would be ideal if there was no timeline at all outside of the timer. nor did the alarms go off. when filtering is not running, all values are out and it creates alarms all around. that is, the alarm only occurs when the filtration is running and the values are out at that moment, and if the timer is ON and there is no flow to the probes, then deactivate the alarms as well. then they are out too. to be able to set it in the application, for example. that would be professional. but this is how it can be operated and it’s great.
otherwise, the timeline in homey must be turned off so that it does not generate errors all the time.

So an option to disable alarms to be sent to the homey timeline when filtration is not active is what is needed?
The second use case can be done in the flow.

yes, ideally you can turn it off and on in the app

in aseko there is also a delay set after switching on the filtration, it should be read out from ASEKO and it should only show active filtration after this delay. it’s currently 8 minutes on mine. I tried it now because at startup it takes a while for the values to stabilize. the temperature and other parameters in the pipes are different than in real life in the pool. it can be edited in the flow, but always edit the flow when it changes to aseko it will be forgotten

is this delay defined in the web application, cannot find it…

on website… attached


Thanks, found it and now running a test version to see if all goes well. Waiting for some errors from your or Carl’s pool

Hi, after the update of aplication, the AND condition is broken. filtration seems to be still inactive. the condition doesn’t respond to whether filtration is on or off

Awww, will check it out somewhere this week…

HI, thanks for update, but it’s still not working. the AND condition always ends with an error when the unit is active. (When the unit is inactive, it evaluates it correctly)

Apologies, i was other crashes i saw. Still need to fix this. Could you trigger an error and send me the log? (goto the app and configure settings, log)

When is filtration active? i have set up my own app and can test more easily

Filtration is active now (after restarting app and ASEKO), but the condition AND evaluates to “NO”. without error now

What is local time at your place?
I think it is not evaluating correctly at my place with your time settings :slight_smile: