[APP][Pro] Archive Insights - export all your Insights data to a NAS, FTP or web folder

The resolution is fixed by Homey for a selected period. So when you select the pas t hour, you always get a (interpolated) resolution of 5 minutes.

Only per app. Not per device or variable.

I just launched a new app version v2.9.2

  • Packages update. athom-api@3.7.1.
  • webdav@4.8.0.
  • Extended error logging.

I’m trying to use the SMB share provided by my Asus AC86U router as the destination of exports.

On my Mac I can connect in Finder (⌘K) by typing smb://ac86u. After entering my credentials (username and password) I can select the folder tmp (at usb) for the /tmp folder on the attached USB drive)

On the command line mount lists this volume like this:

//username@ac86u/tmp%20%28at%20usb%29 on /Volumes/tmp (at usb) (smbfs, nodev, nosuid, mounted by username)

What should I use as network share, subdirectory, and domain in Archive Insights to use this SMB share?

Figured it out:

//AC86U/tmp (at usb) (upper case server name) works, where //ac86u/tmp (at usb) (lower case) did not…

Confusing, since the lower case hostname did work on my Mac (for SMB) and is even required for SSH.

1 Like

Can you help me with the config, i got a error to connect with my NAS. “getaddrinfo ENOTFOUND JN-NAS”
JN-NAS is the name of the NAS in my network
NAS Synology, using SMB as devined in NAS

There are many things that can go wrong, like incorrect usage of /, or FTPS vs SFTP, or use of capitals. So just keep reading manuals and forums, and keep trying different settings.

Most NAS devices support multiple ways to connect. If SMB isnt working for you, try FTP or Webdav

Thank you for your reply.
I just tried to use the FTP option with secure SFTP.
In the NAS is also the secure FTP selected.

Also use the poort as defined in the NAS. Got now a error Undifined (control socket)

Can you help me further?

Sorry not really. It is mostly a trial and error process. The app is targeting experienced / tech savvy users, so the user friendlyness is not very high unfortunately :sweat_smile:

Hi @Gruijter ,

would this helps you to troubleshoot, what’s wrong ?

Diag : a0683871-c15c-44ce-88e9-39f2f756a514
In logs I see :

2022-03-31 06:23:03 [log] app unload called
2022-03-31 06:23:03 [log] memwarn!
2022-03-31 06:23:00 [err] Insights data is corrupt for Home Energy Meter Gen 5_Σpower meter_kwh_last_year
2022-03-31 06:22:09 [log] memwarn!
2022-03-31 06:22:08 [err] Insights data is corrupt for Sonoff charging_Σpower meter_money_last_year
2022-03-31 06:21:14 [err] Insights data is corrupt for Easee Charger_Σpower meter_money_last_year

The mem usage peaks on 100 MB during export triggered via flow - interesting is that

Interesting is that I can’t find if actually any export is missing or not - seems not…

Yes, that is indeed a peak load during export. Not much I can do about it. The memory is freed when the export is finished.

Not sure if you will miss data on a ‘Insights data is corrupt’ message. It could be simply that there is no data in the selected period.

I have Archive Insights on my backlog for a while already. When I have some spare time I want to upgrade is to SDK3, but I also have other apps that I need to migrate to SDK3. With SDK3 comes a new Homey API that might improve stability (but then again, it might not…)

1 Like

Ok, I decided to put Archive Insights on the top of the list to migrate to SDK3.

v3.0.0 can be tested from here: Archive Insights | Homey

  • Migrated to SDK3.
  • Replaced athom-api with homey-api@1.5.22
1 Like

Thank you, seems the crash is gone and it looks like it even finishes successfully :slight_smile:

[log] 2022-03-31 20:50:03 Finshed all exports

… + 5 more exports in the target directory

Well done :+1:

And memory maximum is on 40 MB, no warning in the logs.

1 Like

Tnx for the new version. I had some issues with the previous one and tried your beta. So I am using 3.0.0 now.

I appeared to work better, however, It looks like the selected time-period is ignored somehow. I tried this morning several time-periods (yesterday, last week, last month, last year and today) for a few apps. They alle gave the same result: last 24 hours.

Sone background: I did reset the Homey last night, did not do a p2p yet. Using a Homey “Early 2016”, SW version 7.3.0, Memory approx. 80%. Storage less than 50%

I’ll be happy to do some more testing, just let me know.

1 Like

I need to investigate that then. Is that when using a flow, or when using from the app settings, or for both?

Yes, I can confirm it is always giving ‘thisDay’ as output, no matter what resolution is selected. This is a bug in homey-api (or Athom changed something without documenting it). Anyhow, I reported it to Athom and hope they come up with a solution soon :slight_smile:

edit: this is only an issue in the new test version 3.0.0. The stable version 2.9.2 is working as always.

v3.0.1 is ready for testing Archive Insights | Homey

  • Migrated to SDK3.
  • replaced athom-api with homey-api@1.5.23.
  • Fixed resolution selection.
2 Likes

I just released version 3.0.3 in the app store

  • Packages update.
  • homey-api@1.5.26
  • archiver@5.3.1
4 Likes

Getting an API timeout error with the latest version when I try to export data from the app with by far most data in it. If I limit the export period to ‘today’ or ‘last 24 hours’ it works but complains on corrupt data. However if I choose longer export period (e.g. last 31 days) it fails immediately on API timeout:

[log] 2022-05-01 09:50:28 Finshed all exports
[log] 2022-05-01 09:50:18 APIErrorTimeout: Timeout after 5000ms at Function.timeout (/node_modules/homey-api/lib/Util.js:48:26) at HomeyAPIApp.call (/node_modules/homey-api/lib/HomeyAPI/HomeyAPIV2.js:359:28) at runMicrotasks () at processTicksAndRejections (internal/process/task_queues.js:97:5) at async Manager.value (/node_modules/homey-api/lib/HomeyAPI/HomeyAPIV2/Manager.js:261:24) at async App.getLogEntries (/app.js:475:23) at async App.zipAppLogs (/app.js:824:22) at async App._exportApp (/app.js:863:21) at async App.runQueue (/app.js:224:4) { statusCode: 408 }
[log] 2022-05-01 09:50:13 getting logs related to com.qubino

Tried to export via SMB and FTP but issue is the same. Any idea how to fix?

What happens if you try to show the same insights from my.homey.app?

And what happens if you try to download that same data from https://insights.homey.app/ ?

That works just fine.