[APP][Pro] Amazon - Alexa

Hi and ty for answer.

After removing, restart etc app… i got it back. I think i may have found reason… Every prolly 90 days or so… guess due login rules Amazon? the app loose connect and i need to “add” them again in homey app… Since i have a new network home… the refresh did not work. Had to connect to the same network that Alexa etc was on… then all smart plug’s was up running again.
Don’t know if this was the reason, but next time they disconnect i will try refresh/add them on the right local network first… Then i know :slight_smile:

Hey. @Jamie Thx for the response.
Using smart plug.
Problem seems solved at the moment.
What i did:
Deleted 1 device and reconnect him to homey as smart plug like i did before. Suddenly all the other devices started working again.
@Mwinte maybe this is also a solution for you.

Hi, you do not have to remove. Just add, smart plug. Search then go back. My problem was local network. Added New 1000mb wifi… And Alexa Was on old… So awitched Mob to old network, add smart plug and all was up running again.

There is a new test version of the Alexa App :

Hopefully this will remove the logger error from ‘other’ device types, it also attempts to add a new type of Alexa Show 5 (gen2) devices. - @Cyril

Finally it also reduces the verbosity of the errors coming in, now that this version has had some testing.


Hi Jamie just wanted to say thanks for a great app, top work, I use it a lot.

Could you also add the Echo Show 10 gen 3 device please

Many thanks

Hi Everyone,

I have updated the app and submitted it for approval by Athom, when I lasted updated the app they mentioned that the app image (which is currently just a logo) doesn’t met their standards and the image should be "“visually appealing image that represents the brand”.

I agree with them, however its not something I am capable of doing, I thought I would ask the community if anyone could help provide an image so I can continue to submit this app to the appStore

— The App Image shows the brand logo without a background. This is not up to our standards. make sure to add a visually appealing image that represents the brand.
For more information and examples check our App Store guidelines section 1.4.2. App Images.

Guidelines - Homey Apps SDK

Consider implementing the given feedback in your next update, to make the most out of your App Store page.

Resolutions for the app image:

  • Small 250 x 175
  • Large 500 x 350
  • XLarge 1000 x 700
1 Like

Amazon press site has some branding images Devices
Maybe use one of those?

I looked for a press kit, but couldn’t find it, this is fantastic thanks.

1 Like

I have pushed the latest version to the public channel : Thanks @OH2TH

1 Like

New minor test version is out :

Adds new flows for the Echo Show 5 (gen2) (@Cyril this should fix your issue).


1 Like

I confirm : the show 5 gen 2 have all “Then…” actions !

Great ! Thanks a lot !

It would be brilliant if this could be added

@gy_1977 - please see the FaQ section on how to request a new device.

Hi Jamie this was my best shot. Where would I get an image

Hi Jamie, I am trying to add my Alexa echo dot (gen 4) as a device on Homey. However every time I look for it it tells me no new device found. I managed to add my echo dot (gen 3) with the blink of an eye.
I also tried to take the gen 4 closer to homey but that changed anything. My Alexa app is 5.3.8 and I am on new Homey Pro (2023) release. I am based in Germany Thanks a lot

How close an item isnt really important - so long as both devices have a good internet connection.

I would have to check, but I dont think that the app has support for gen 4 dots (or echos). I don’t own one myself, and no one has provided the information so I can add it.

I am thinking about how I cam make adding new devices much quicker and easier, but the downside is that all your current devices would need to be re-added. Not sure if it is worth it.

Hi I think the app has the option to add the echo dot gen 4 because it appears in the list of devices.
The one circled in red is what I am trying to add.

There you go!

Thanks @GianmarcoCicuzza

Ill see if I cant figure it out later, if you restart your app wait for the devices to come online and thens end me a diagnostic report that may help me find the right ID for you. I will also need the name youhave called your Gen4 dot.


Hi Jamie, the echo dot 4 gen is called Alexa Cucina.
Here is the report c912ff89-ef3d-4d99-ae40-1caf2b96a7b3

Since I am new - could you please advise on how to restart the app? Do I need to simply disable and re-enable or I need to disinstall and reinstall the app?

Thanks for your help

In regards to adding new devices I’d certainly support this even if it means I need to re-add everything

It gets my vote

Appreciate the hard work @Jamie