[APP][Pro] Alsavo Heat Pump for Swimming Pools

Good morning Gal

At this time, I can only report that Homey is connected to Alsavo :muscle: And today’s promising day with lots of sun will put it to testing and it will have a some start/stop via flow in Homey. let’s see and I will report to you later in the day

Michael

Thank you, Michael!

It just works great so far!

Now - we have a field for delta-T - if you REALLY would like to nerd-out with it in a future update, you could:
Add a manual input field in app settings where user put flow rate (fixed estimate, or variable from other device), then you could add a calculated capability using Q=m * Cp * dT to calculate the power the heat pump provides to the water in kW :smiley: :smile:

Power [kW] = mass flow [kg/s] * specific heat capacity [kJ/kg°C] * temperature difference [Δ°C]

  • mass flow kg/s can be converted in code from flow rate eg. 3600liter/hr~1kg/s
  • specific heat capacity can be hard coded 3.85 [kJ/kg°C] for water, or set by user in settings
  • both values above depend slightly on salt vs. fresh water (density and heat-capacity). A selection/drop-down could select between hard coded values for both.

…and you can even (now we’re really getting deep), subtract the live-energy the compressor and fan is using - which is also known - and calculate your “live-COP” :nerd_face:

Sorry for nerding. In any case, i am already happy with the APP!

ps. i tried both of these by just calculated logic variables, work pretty good - but they are approximates!
image

1 Like

@Gal_Carmeli

Hi Gal

My flow start up the Alsavo heating pump, but now it has lost the connection again between Homey and Alsavo

Unfortunately, I cannot send a diagnosis report from Homey. as I have a bug that Homey support is working on. I get this Rate limited error every time I try to send a report.

Darn… I can’t do much if I don’t have the logs…
Cn you please check which app version do you have?
When you restart the app, the connection is restored?

@Michael_von_Barner - one more thing - look at the value of the last capability: “Last Update Time”.

WhatsApp Image 2024-05-16 at 15.31.06_7ba0bf5f

The time mentioned there should be “fresh” (smaller than 5 minutes ago).
Is this the case? What does it show?

@Gal_Carmeli

The last update time was up to date within some seconds.
It helps to restart the Alsavo app, and after that it could stop via Homey.

Wow!
Cool stuff, but I think it’s too complicated for the average user to configure and to use.
I will leave it in the hands of the super-expert users to implement this by a Logic-flowcard, similar to what you are showing.

Hi Mainnsto

I think it looks exciting with the calculations you can now do, but how and where do you do it in Homey?

I just can’t find the “apps setting” that I think you mention in your text?
Would you like to help me a little more along the way?

Michael

I made the calculations with a flow and the in-built logic-functions. First i made the numeric variables to store the number in, then i calculated them all in the same flow. These are so far proof-of-concept and require some extra work. Eg for small numbers (or sensor noise) in power calculation you can end up with very high COP :slight_smile:

Edit: For consumption i added the fan as a static 30W, i think its rated between 5W to 35W, so its not alot compared to compressor, however it should be set to 0W when it
s not running.

1 Like

@Gal_Carmeli

I have tested a little a work today. And after about 1 hour Homey lost the connection to Alsavo. If I restart the Alsavo app it’s working again. I can’t still send diagnoses report :face_with_raised_eyebrow:

@Michael_von_Barner -

  • Which app version do you have?
  • How did you determine that the connection was lost?
  • When the connection was lost, what was the value of the “last update time” capability:
    WhatsApp Image 2024-05-16 at 15.31.06_7ba0bf5f
  • Which app version do you have?

V.1.0.4

  • How did you determine that the connection was lost?

and I know my flow has told it to stop, so it’s still running. then I can see when I go into the Homey app that it says that it is turned off (Homey thinks it is turned off) If I then try to turn it off manually from Homey, it does not respond. it is only when I restart the Alsavo app in Homey that a connection is made again and then I can switch it off via Homey

  • When the connection was lost, what was the value of the “last update time” capability

It says that it has been a few seconds since it was last updated

I am not sure it lost connectivity. In the “last update time” is fresh (meaning, smaller than 5 minutes), it means that the app got a communication from Aslavo.

Based on your description. it seems like the functionality of turn on/off doesn’t work properly.

Next time it happens, please do the following:

  1. Click on the Turn-On / turn-Off capability on the Homey app:
  2. Open you Smartphone app, wait for 1 minute, and see if you action on the Homey0App is reflected on the Phone-app. For example, if you turned it Off on Homey, make sure on the Phone app that it was indeed turned off.
    Repeat that action a few times.

Let me know what happened with this test.

I can only do that tomorrow after 12

But I have tried to do that action the other times and nothing happens in the Alsavo mobile app when I press on/off in the Homey app

And the “last update time” was fresh? (less than 5 minutes old)

Yes it was :wink:

Then something is wrong with setting the values, but the connection is not lost…
I must find a way to extract logs from your device.
Let me sleep on it.

I can’t seem to get mine to work right, I can turn it on in Homey by clicking on/off and via a flow, but it’s not reflected in the Alsavo App and pump stays off.
Last update time shows secs. ago

Great, so we have a reproduction of the issue.
Can you please try again to turn on and off a few times, and immediately after send diagnostics-report?