Aqua Temp pool heater

Is anyone else started to work on an integration for Aqua temp ‎Aqua Temp i App Store

I have solved so setting heat, onoff and also getting values for inlet, outlet, power consumption and more.

there’s an app request for it

What you’ve already done is all I need. Would you like to publish your app? :pray:t2:

This is what i have now. Will try to add everything required for publish.

1 Like

Looks great. I turn on/off my circulation pump with Shelly Pro 4PM, and when circulation starts my heating also starts.

With your app I will be able to enhance my flows with reading and setting temperature, and maybe also get info about energy consumption of my heating pump? Shelly only gives me consumption for the circulation pump…

Yes i am measuring how many KwH is consumed. Hopefully i have some time during the weekend to publish it.
If you want to contribute. GitHub - ludwich/homey-aquatemp: An app for homey to get connection to aqua temp

1 Like

App is now in Certification and that can take up to 2 weeks. Have it installed locally and works nice to adjust heat to electric prices in sweden from Tibber.

1 Like

Wow! Great job :slight_smile: Also using Tibber, in Norway. Looking forward to test it!

The app is live. Fill in your account details in settings and add the pool.

1 Like

Thanks! Tried to install, but can’t get it working though. I was never asked to login…(?).

Debug: 73790291-2180-4608-a3fe-e56e4190e646

You have to add username and password on app settings.

Thanks for the app Ludwig!
But I still dont get it to work even though I enter my credentials in the app-settings.
I have tried to change my credentials in the Aqua Temp App, changed username and password. Restarted the app…
Any idea how to get it to work?

Send the logs and i will look at it.


Thanks! :slight_smile:

Hi ludwig
Love to get this app working but I’m struggling with the same issues as above.

Login credentials seems invalid somehow.

I was using the wrong credentials, my username was not the same as is displayed in the app. So when I got that sorted it worked fine!

No the username is your email. Will update the settings page to show this.

1 Like

Is the power consumption actually working?
It stays at the same level and the cumulative consumption is blank.

I have got some data in Insights but are experience the same issue as above.