[APP][Pro] Advanced Virtual Device (Device Capabilities App) with Unique Text Status Indicator

Now in Test:
A when Status text/number changed flow card.

And a bit of a messed up App Templates, i was working on that…

2 Likes

Pff, finally got all views on all phones and devices the same and working correct.

Old iPhone settings are also working, only have some issues with the old ios Create Device.
Ill work on it later.

Hi Arie,

DC v2.6.39-test

I just imported this flow


But somehow, the variables don’t get presented as variable everywhere, but their ID is shown instead. The variables were created fine by your script


Here’s a Var ID check, it returns a just created variable, used in the flow

Okay, ill fix this.

Because looking at you picture, it show that the reference ends with ]] but the dont open with [[, so somewhere i have made a replacement error.

1 Like

Somehow the new device stays unaltered when importing this device:

App v2.6.39-test

Restarted the app, tried several times, created a new AVD before every import.

I also tried with an edited AVD device myself, the new AVD does not get altered after exporting and importing the TEF and use a new AVD as clone

Resolved in nieuw test version: 2.6.40

This is not an general issue ( for me, everything works fine).
Please send me a diag after App restart and lets continue in in PM.

Hi Peter,

Is there any way to get rid of that leading 0? Show if I want to show the time in the tile, it will only show the time like: 22:15
Instead of: 0 22:15

In the Web App, yes you can replace it with a Dash (-) by using the Set Status Card with Number and leave number empty.
But it will then show nothing in the Mobile App.

Athom (might) be working on it, i have had contact about the difference in Web en Mobile App en asked that, since the need to straigten the difference out, the nicest thing for users would be that units wil be displayed with an empty value if the value is empty.

And it could be done, because there normally are no apps that leave the capability value empty. Athom didn’t even know about the difference between Mobile and Web when a device capability value is empty.

But we will have to wait and see.
As a developer, i cannot do anything about how the numbers + units is displayed. Only Athom has the ring of Power for that! :wink:

2 Likes

Ok, Arie. Thanks again?

1 Like

Hello @Arie_J_Godschalk ,

Thank you again for your exceptional work. I wanted to know if in the area surrounded by my previous message it is possible to put only text without a number. I would like to indicate the states of my vacuum cleaner for example “docking”, “charging” etc…

Thank you very much!

Edit: I just saw that Dennis had the same question I believe.

I hope it will be, lets see what Athom makes of it.

This is A Petition!

For Everyone who wants a Text Status Indicator (as Device Tile) without a zero or dash in front of it, HIT the Like button of this post/message!

image image

If we get enough likes, we can include Emile or someone from Athom, to show them how much people would want this!

Please Like and Share!


Update: Message has been send to Emile:
Dear Emile

76 Likes

You can try the alternative Exchanger file. You’ll need de H.o.o.p. app though

Peek 2022-09-13 02-27

Link:
https://community.homey.app/t/the-flow-exchange-r-hcs-edition-exchange-your-flows-with-others/69556

hehehe
Screenshot from 2022-09-26 13-44-08

hey @Peter_Kawa , in the version is just pushed to Live, the variable creation is completly fixed as far as i know: droptokens didn’t get linked correct after creation.
This is now solved.

The EV Charger Status Device Tile - AVD Template import correct now (if you don’t have the variables allready).

Still an issue when finding existsing variables i see, fixing it now.

1 Like

Fixed in allready currrent live version!

Here i import a Flow from someone else, but with the same variable names as i allready have got (because i allready imported the flow).
image

Now there will not be an error, but it will replace the variables in the flow with yours (that is, the same name, but other IDs)

1 Like

It looks better indeed, Arie.


But now I’m missing ‘wires’ somehow, but not all are missing.

Create it with the latest file please.
I think you have created this file with the Live version that had a bug.
It does not in the newest live version.

The bug was in Export, when creating a file.
The bug was live about 10 minutes, 30 people did get the install with the bug tho.