[App] Eurotronic Technology App (Stable: v3.0.1)

I have 8 spirits they are setup with Secure RT321 Thermostats per room.

I just picked up 8 Secure/Horstmann/IQE RT321 Thermostats off eBay at approx £20 each

I am using the Heating Scheduler to drive them right now.

Having to use a non Homey zwave Controller to control the Secure SR302 Heating/hot water right now until the bug in the Secure/Horstmann app is fixed :-(. Only thing stopping running everything on Homey.

Nope, but I didn’t give it a try aswell. After some research I decided to go for a solution that would provide multi zone heating in an autonomous system. Stability is one of my requirements so I went for Evohome. There is an Homey app for it so you can extend some functionality that Evohome laks. The radiator knobs can be purchased for around €60,- in Germany and on eBay.

I have problems with sending the actual temperature to the spirit.
I have activated the external room temperature (advanced settings) and send the temperature from a wall thermostat with a flow to the heating thermostat (spirit). This does not work really well. There are always changes in temperature.
Above: Temperature profile Spirit Thermostat

Bottom: Temperature profile wall thermostat.

The two temperature graphs should look the same?

Is this a bug? Or am I doing something wrong?

if you enabled external temperature, then the value shown is that what you send to the thermostatic, not even what the device measures anymore.
So it can only be 1 of the 50 different possibilities, as i’m still not a mind reader it is only a guessing game now.

but most likely it is either a 2nd flow that also sends temperature, or you did something else of 1 of the 49 other possibilities wrong.

Hint: Give more information! app version, homey version, did you check any flows, did you check if any other device sends temperature to the spirit, what have you all tried to find what could cause this.

  • homey v2.1.2
  • Eurotronic App v2.0.6
  • There is only one flow that send the current temperature to the Spirit Thermostat.

The temperature profile of the spirits looks like as if the internal temperature is detected from time to time and then again the external one.

I would also rather work with associations than with flows.

Unfortunately, I can not put any associations with Devolo room thermostats, as there is no input option in the settings ?!

there should be at least 1 association group, every z-wave device needs an association group or it is not a valid z-wave device and will never work with any z-wave device or controller. (It might be an german language bug, and you should definitely contact Athom about it)

But i’ve never received any measure temperature from the device as soon as it turned on the external room temperature, so it is kinda weird that it happens for you.
I’ll see if i can catch that in any way :thinking: not sure when i have time for it though.

Each of my Z-Wave devices has at least one association group except Devolo Heating and Wall Thermostats.

I will report the error to Athom.

THX :grinning:

A question about the valves, but not App related.

Does it wear out the battery if you change the setpoint?

In my case I leave the valves ‘active’ during the summer: they follow the heating schedule of winter, but the central heating does not pump warm water thru the valves.

Would ‘hibernating’ the valves - in my case 4 Spirits - save battery?


Ofcourse, it needs to wake up more to receive the setpoint, and send out a signal back that it received that signal

Thanks Caseda!

I forgot about the sending part… I will edit my flows to avoid this in ‘non heating’ season.

Which is coming :blush:

This is a question to Caseda (sorry, I don’t know how to post it otherwise):

Hi Caseda!

I am referencing this closed issue
and would like to add a question:
In the case that Mindsuk describes, does your answer mean that what the thermostat shows is incorrect and in reality it is regulating the room temperature to what the homey app (and homekit) show?
I am asking because I have the same issue and found out that when I press a button on the thermostat, the display immediately switches to what Homey shows.

Thanks a lot for helping me understand.



There is a nice official topic for this app.
I’ve moved it to there.

The device has 3 different “target” temperature values in its memory.
Comfort temperature, economic temperature and the off temperature.
Off temperature is not changeable.
The other 2 are, the gui will always change the comfort mode, even if it would be in the economic mode.
This is just to stop confusion like I addressed in that github issue.

If you press the + or - button on the thermostat when it is in economic mode it will switch to comfort mode, this is done by the thermostatic itself and not Homey, I / Homey can’t change this behaviour.

So Homey has kinda the same behaviour when you move the temperature, so to stop this confusion that happens on the thermostatic, I only show and change the comfort mode from the GUI.

If you press the middle button it will always go to boost mode, this is also not behaviour I can change.
And fully determined by the thermostatic.

His question was that if the thermostatic is in economic mode, that it still would display the comfort temperature target, and not the economic temperature.
But as you already notice on the thermostatic itself, it is really hard to implement well, and this was just what could cause the least amount of confusion.

I have the same flow as you, sending the temperature value to the Spirit each time the temperature changes, and I have exactly the same behaviour.
When a temperature value is sent to the Spirit, the Spirit reports that value for a while, and then it returns to what is probably its internal reading.
However, I don’t think this affects the actual temperature regulation of the Spirit, so this is probably not a big deal.
I’ve attached Insight-pictures from three different Spirits. In each picture, the upper graph is from the Spirit, while the lower graph is from the external temperature sensor.

Spirit2 Spirit3

I have 2 issues

  1. When external temperature sensor is used, the thermostat heats and heats without controlling against the target temperature

  2. When using the Economic mode, the correct temperature is sent to the thermostat but not displayed in the app! The same fore mode OFF!

Homey v2.5.2
App v2.0.7

  1. Depends on what external temperature is in memory/you are sending of course, I have no further control over the valve, it takes care of opening the valve more or less on its own, this has not changed at all since the start, make sure you are sending proper temperatures/configured your direct association properly.

  2. The target_temperature capability will always show the comfort mode temperature, not any of the other mode’s temperature, this is by design, and will not change, as people might see it as also changing the economic temperature with it when in that mode, which is not possible.
    You can see (and set) the economic temperature in your advanced settings.

Concerning point 2 I have to carefully say:
Hmmm, I don’t think so.
Correct me if I’m wrong but I set up mine as follows:

Valve using external temperature sensor.
Valve using external target temp as target temp.

WHEN Temp sensor X changed temp THEN send room temp to Valve.
WHEN Target Temp of Heating changes (mine is a Tado) THEN set temperature on valve to that target temperature of heating.

The valves remain in comfortable mode all the time but the shown target temp is automatically the target temp of the heating (tado).

He’s talking about the temperature shown in the GUI when it is in economic mode, not sure what you are talking about, but you aren’t talking about economic temperature it seems like, which isn’t shown in the target temperature of the GUI, your way of working with the app is entirely different then his point.

Hi!! Received my Spirit devices today. I tried to connect them to Homey via the app and general zwave but it doesn’t work… Homey is on version 2.5.2 and therefore not allowed to install the beta version of the app. What am I doing wrong?

And you are sure you have the z-wave version and not the zigbee (not supported) version?
if so, what doesn’t work, if it doesn’t include try resetting the device.

Yes, it’s a zwave-plus version. I pressed the boost button and the light starts blinking and device is in ‘Inc’ mode. After some time I get messenger that no z-wave device could be found. I placed the device next to my Homey.