[App] Eurotronic Technology App (Stable: v3.0.1)

That’s not an z-wave app though and not sure the device the questioner is taking about is zwave too?

If they made zwave asynchronous, then every device will break after +/- 10 minutes, so most likely not

Thanks. I’m just searching for a reason for the current behavior and try to exclude possible options :innocent:

Hello @Caseda,
I had the same sitatuion again. The thermostat was not changed, but the Homey app reports the new target temperature. So in the app I can see 22°C, but the thermostat has still 18°C.
Could it be possible, that Athom changed something and error responses are not sent back to your app if a value could not be set?
In the past, the old target temperature was visible in the app device if it was not possible to set it in the thermostat. So I could react on if the wrong temperature was shown in the app (or dashboard).

Do you have a chance to check this behavior (if the error handling was changed by Athom)?
Thank you in advance.

I see this behaviour too with other devices sometimes. The Homey app is not in sync with the real situation. Can you confirm that the values are properly displayed on: http://developer.athom.com/tools/device ?

If that is the case its an issue in the app. If not, it’s an issue in the Homey sphere or the app.

No, the DEV-page has the wrong target temperature, too.
It’s displayed in Homey app and HomeyDash.

The device capability target_temperature has 22°C and the thermostat itself has 18°C.

Does your app set back the target temperature to the previous value in error case?
Or does it just set the device capability and Homey has to handle the error itself (and set back the previous value)? Then it’s an error which should be reported to Athom?

It is a little bit of a combination.
the app sets the value in Homey,
Homey sends this value to the device and waits for the acknowledge back of the device if it received it.
If yes then, and only then the app will say against homey that it was OK to use the new value.
If this acknowledge doesn’t get received the app will tell Homey that it failed, and Homey then did put back the old value.

But a lot has changed, even without our (the developers) knowledge, so currently i have no clue if anything was changed in such a way to change/break this behaviour and if it needs to be fixed on app level or something broke on Homey level.
Unfortunately, I don’t know if i have any time in my christmas holiday to debug this.

Hi, I didn’t want you to break your holiday :blush:
Just wanted to report/comment this behaviour. So if you have an idea and I can help you to test something, then please write.
Until then have a nice holiday :christmas_tree: and happy new year :clinking_glasses: :fireworks:

I tried to add a new StellaZ to Homey, but the pairing doesn’t work. Step 1 is succesful, but the interview phase does not seem to start. The ZWave logging:

2020-01-06T20:22:06.829Z Command[589] start: addNode
2020-01-06T20:22:06.848Z Command[589] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
2020-01-06T20:24:33.655Z Command[590] start: addNodeAbort
2020-01-06T20:24:33.658Z Command[590] end: addNodeAbort
2020-01-06T20:24:33.767Z Command[589] status: addNode, status: ADD_NODE_STATUS_DONE
2020-01-06T20:24:33.768Z ProcessAddNode[572]: Error: aborted
2020-01-06T20:24:33.771Z Command[589] end: addNode

Does anyone have any suggestions? Thanks in advance!

@Caseda if I want to send the room temperature to a Spirit via flow, what do I have to enter here?
I know I can do it also out of the box.
But I’m interested on the raw Parameters.

Thanks a lot.

If your valve is included secure, then that card won’t do anything, even with the right command.

And if it’s include Unsecure?
And how did you managed it within the App?

If it is included unsecure then it is possible, but ill have to search the hex numbers, as I’m not at home this week, I can’t search for you yet.

The app knows your device is included secure, that (generic) card doesn’t

Hi guys,
I got my Homey for 4 weeks and I am amused to see how I can easily feed my Spirits with the room temperature from external sensors via flows!

Unfortunatly, I didn’t managed to do that with a direct association. I have tried with folowing temperature sensors:

  • Philio PST02-1C 3 in 1
  • Heiman temperature sensor
    I couldn’t include them in secure mode, is that the reason?
    Which sensor is working with the Spirit for a direct association?

Many thanks for your help!

yes, only secure devices can send (external) temperature values with direct assoctiations, for this reason i implemented a flow card that can also send this temperature to the valve, so any temperature sensor can then be used.

Thanks @Caseda for you answer!
Can you please tell me with which sensors you successfuly associate the Spirit with?
The other way around, is it possible on Homey to include the Spirit non-secure and then create the association with a non-secure included sensor? If yes, how does this go?
Many thanks for your help.

I’ve never tested direct association with my spirit, as I don’t have any control over that part there isn’t much use to test it (and don’t use that way either), only from flows to make sure that works as that is my implementation.

It is possible to include the thermostatic unsecure, but you’ll have to edit (add) part of the code and then re-include the thermostatic.

To send the current temperature to the Spirit using associations the temperature sensor must support the Associations Group “Sensor Multilevel Reports”.
Like the Secure SRT321 does it. See manual Secure SRT321 Association Group 5.

E.g. Fibaro MS or Aeotec MS you can not use, because those doesn’t support the needed associations group!

Hallo @Osorkon,
I had a look on the SRT321 and I am wondering how you include the thermostat. According my researchs, the SRT321 is not supporting secured inclusion. I have checked for both Z-Wave and Z-Wave + versions (has you mention the group 5 for “sensor multilevel reports”, it seems you are using the Z-Wave version).

@Caseda, can you tell me a bit more concerning unsecured inclusion? Is there somewhere a tutorial?

Many thanks guys for your help! :wink:

I don’t own a STR321. But you are right the STR321 doesn’t support secure Inclusion.
So Associations between Spirit and STR321 only works if you are able to include the Spirit Unsecure.

Why it’s not possible with Homey to choose between secure and Unsecure Inclusion like a lot of other Z-Wave Gateways offer, I can’t understand it!

Hi! Finally, it seems that I’m not the only one to struggle with my Eurotronics … temperature is completely crazy, sometimes it’s freezing (15° in the kids bedroom while I ask for 18.5) and sometimes I wake up in the middle of the night and it’s 22 in the kitchen…
I have bought around 15 devices for 2 floors and since the beginning nothing is working. I’m quite new to Homey so I thought it was my flows which were completely wrong but apparently no.
Do you have any news on your side ? I’ve seen the Jeedom forum about the Aeotec / Eurotronic issue. If someone needs a translation, I’m french if it can help.
If I can’t find any solution, I think I will sell everything and move to netatmo!

1 Like