[App] Eurotronic Technology App (Stable: v3.0.1)

In the slack of read about homey problems with FLIRs devices. The reason is apparently an incomplete implementation of FLIRs. The more FLIRs devices in use, the less reliable it becomes.

Thanks for the feedback, so it’s Homey’s FLIRs management that is in cause here ?

Really would like to know the answer to the ‘out of control’ Eurotronic Spirit. I have the same issue over here. Temperatures regularly exceed the set temperature. Even though I am updating the externally measured temp every 5 mins with a seperate flow. Valves just don’t close.

had the same problem with the spirit valves. purchased several of them. completely random as to whether they respond to homey or not. gave up on them in the end and went back to using the POPP trvs. very expensive mistake. to be honest, im giving up on homey for now. have ordered the fibaro HC3 and hopefully will have more success with that. wish me luck

Hello everyone,
I purchased 2 weeks ago a Homey and a Eurotronic Spirit and have been trying to get the Spirit to work;
To sum up, manipulating the Homey sphere lights and messages out of homey is easily doable, so that works. I would appreciate a central explanation (video or manual) of how Homey flows work, but I can survive. Which is no the same as being happy, as you might guess. As developer mode is java, and I have no intention to learn java just to run radiators, I will skip this, unless I really have some project in mind later.
That leaves me to run the Spirit with flows.
I have put the Spirit in the same room as a Netatmo thermostat. And defined the parameter of the Spirit as external. I thought I could run the spirit from there using apps and flows. So far, not quite.

  • the Spirit reacts immediately to manual changes of the thermostat mode. At least therefore it does connect with the iphone.
  • but attempts so set spirit thermostat temperature through a flow have not worked. Insight does confirm that the temperature should have changed, but this has not filtered down to the Spirit proper. Lost in communication somewhere therefore.
  • I have tried to use apps, with little success. Temperature monitor does not seem to much impact the Spirit. Nor Eurotronic Technology. They pretty much show the same thing, so when I set temperature in one at 28C, this figures shows on the other app, but not on the Spirit. And of course Homey Heating Scheduler, which would have looked convenient, does behave in the same way.
    So, I have a communication problem between Homey and the Spirit. Can it be solved? Should I dump the Spirit? The Homey? Both?
    Happy to hear all your kind advices.


Unfortunately I am having similar issues. All worked well for months, but recently I see communication errors to my Spirit valves. In my flows I have made extra actions card (just in case), but that also fails to work:

Oddly enough, sending multiple commands with a delay is not working great either:

So, the good news? Yes, it can work. It has worked for over a year for me, with only a rare comm error. The bad nes; it still remains unstable and is not 100% reliable.

I will file a report to Athom.

Early 2016 Homey with f/w v4.0.0
Eurotronic App v2.1.0

Hi, I have a couple of Eurotronic Spirit thermostats, and all of them sometimes goes crazy - they heat too much, despite reaching target temperature they don’t close the valve. I don’t use sending the temperature to device - they use their own thermometers. And they even report correct temperature - yet they keep heating. Honestly I’m fed up with this - luckily now it almost summer, so heating won’t be needed any more, but probably I’ll buy some other thermostats later in winter :frowning:

And you did make contact with eurotronic themselves right? As I’ve seen messages come by that a firmware failure sneaked into a certain batch of the thermostatics giving this exact issue you are mentioning.

Good hint, I will contact them. But just to be clear: even if there is a firmware update which solves that issue, I won’t be able to install it using Homey, right?

They probably can/will offer replacements with updated versions, but indeed updating z-wave device firmware with Homey is currently not possible.

Could you specify the firmware version that is buggy? The firmware ID’s for my 4 Spirit’s - as seen in device settings - is three devices with 771 and one with 769.

All of mine are 769

I am interested to buy the Eurotronic 700088 luchtkwaliteitssensor Z-Wave Plus luchtkwaliteitssensor. But I guess it’s not possible yet to use this sensor with the Eurotronic App? This sensor can measure CO2 figures, so it would be great if this sensor could be connected to homey.

As it isn’t released yet that will be very difficult to even buy it. :wink:
But once it is released it will definitely be supported.

1 Like

It’s possible to buy it:-)


Thanks for letting me know, let me ask eurotronic about an update on this, will most likely be added really soon (code is already done for 95%, just testing is needed with such an unique device), so question will currently be, when, not if :grin:

1 Like


Do you actually get an answer form them? I have used their contact option on the Eurotronics website and sent them 3 e-mails in two months time and have never had an answer. (Question is about updating the firmware of my Spirit valves).

Not very gründlich…

Yes, most of the time, but I do work together with them on the app, so I might have more contact points. :stuck_out_tongue_winking_eye:

What is your question about firmware updates? Maybe I can answer your question already,

This was my e-mail:

Dear Eurotronic team,

I own 4 Spirit z-wave valves and have found out that one valve does not always work properly. It sometimes keeps heating after the setpoint has been reached.

The firmware ID’s for my 4 Spirit’s - as seen in device settings of my Athom Homey controller - is three devices with 771 and one with 769. The one with firmware 769 has some problems.

Can I update the firmware myself? Will this solve the issue? How do I update firmware?

Thanks for your help!