Z-wave mesh problem

After updating the Eurotronic Technology application, which uses the new driver, working with thermostats has become a hell. they are not permanently connected. To transfer commands to them, I had to put the transfer of these commands every minute! The Homey connection with them goes along the longest path, even with thermostats in direct line of sight, without barriers, at a distance of no more than 2 meters, goes through another room!

Please help me solve this problem!
True, these thermostats are unique z-wave devices with a secure protocol.

Remove/add device, or
Cut power for some of the devices used in the route and in developer page hit Heal button. After a while send basic on/off command and than refresh a page to see if it changed.

I tried, did as you advised me.

  1. I managed to add again, only with 4 attempts
  2. Ways are constantly being rebuilt
  3. The problems are not gone.

The update of the mesh-driver has no changes in the workings of security protocol or the routing of the devices (it even can’t change that), it only makes it easier for developers to talk with the z-wave core of Homey, and there have been no changes at all in the parts where this app uses the mesh-driver.

The routing, and taking care of the secure protocol is being done by a layer below the mesh-driver.

But to fix the issue, have you tried removing the power of Homey for several minutes (10+)

For some reason, I have no problems with other devices, for them I do not need to send commands constantly to achieve the desired result.

By the way, it seems strange to me that the command to the device is thrown into the “garbage” after 30000ms, especially for devices powered by batteries. as far as I know, these commands should be stored on devices with constant power and be rewarded with awake from awake.

the 30000 ms is an internal timeout of Homey itself to let the user know the command was never finished, this is the same for all devices, z-wave and non z-wave.

your thinking way is for normal battery devices, not for FLiRS devices like the eurotronic spirit (though, you never even mention that here that it is about the spirit) which should respond immediately on all commands, and Homey also thinks this way.

I read about this technology. I had no such problems with the zway software product. but unfortunately there were many others.
What can be done with this?

Best Regards,