[APP] Aqara & Xiaomi Smart Home - A different kind of Smart Home solution (Zigbee App)

I am trying to decrypt which issue you describe is related to which switch version.
Could you help me to provide a more detailed issue description?
I don’t have the Aqara D1 single or double switches myself.

H1 switches are not yet supported; so that is expected behavior

hi off topic sorry my zigbee mesh network collapsed from one moment to the next. Any idei how can fix it? try restart homey recovery homey not work. Look likes no online all device, bit wifi network is good and hue lights working hue hub and I can maneged homey app.

Thanks for reply. What kind of tool should I use to get more detailed information you can decrypt? Could you please give a pointer to such a tool to get necessary information you need?

I will be finalizing the v1.3.3 update of the Aqara app today and push it to the app store, with the following updates:

Added support for the Aqara Single and Double H1 wall switches (L).
Extended support for these switches, providing the option to decouple the button from the relay (and trigger other flows with these buttons) will be added in a next update.
I don’t have the H1 wall switch with Neutral available; will need to wait before adding support for those.

Support for the Xiaomi devices will be added to the Homey Cloud domain. I did some additional testing and don’t expect that keeping the device awake is longer required (main reason to not add them before)

Not decrypting code, just trying to understand which devices you are referring to with which problem.
Previously you referred to the Aqara D1 switches, but I think you are actually referring to the Aqara H1 switches that will be supported in above mentioned update.

In general (to all users):
When referring to devices in this topic, please be as explicit as possible; if possible by using the product codes on the device itself.
In case of the “Aqara H1 Wall switch without Neutral” this would be WS-EUK02
Alternatively, when added to Homey (even as generic Zigbee device), you can use the productID as shown in the device settings > Advanced settings > Zigbee device information.
In case of the Aqara H1 Wall switch without Neutral this would be lumi.switch.l2aeu1


Try pulling the power plug from your Homey for about 10 minutes.

Is it maybe possible to add this to the Aqara T1 devices?

@TedTolboom could you add support for Aqara roller shade(lumi.curtain.aq2)?

1 Like

v1.3.3 of the Aqara & Xiaomi Zigbee app is available in the app store, waiting for Athom’s certification.
The Test version can be found at: Aqara App for Homey | Homey


  • Add support for the Aqara H1 wall switch (no neutral), single and double
  • Fix issue with filtering of devices for Homey cloud
  • Add Xiaomi devices to the scope for Homey cloud; no longer needed to keep awake

Since last update, i have a aqara mini switch that dont work. I tried new batteriets and removed/add but no luck.

Any suggestion?

Same problem here, @TedTolboom can you solve it please :slight_smile:

Thanks for reporting!
Should be fixed in v1.3.4 currently in the Test environment of the app store: Aqara App for Homey | Homey
Can you check and confirm that it is fixed?


Indeed I had trouble with D1 single and double wall switches.

Yes, now it works again after 2 restarts of Homey. Manu thanks for quick solution.:+1:

Thanks for reporting back.


  • Add support for the Aqara H1 wall switch (no neutral), single and double
  • Fix issue with filtering of devices for Homey cloud
  • Add Xiaomi devices to the scope for Homey cloud; no longer needed to keep awake

I did a code check in these two devices; but didn’t spot a strange thing. Even comparing the configuration with other automation platforms.
I don’t have these devices myself, so I can’t reproduce / test myself.
Can you share, in a DM, the output of the interview of both devices, from: Homey Developer Tools

I will do so with the developer tool later and report.

yey, thanks! Xiaomi temp sensor works now :smiley:

1 Like

Works! Thanks :+1::+1:

thanks Ted

not work for me single device. When I add say device is unavaible. And duble switch is separete it is normal? lett and right switch, but duble is work fine.here diagnostic report 52be5d06-3f28-4989-9f26-319aa250694a

Thanks for reporting; looking into it ATM.