Android logo shows on starting Homey mobile app.. Performance Pro 23 down :-( Athom busy with improving performance

Hi there,

I might have a problem. Since today my Homey app (on Android) lost it;'s performance. It has become very very slow. I restarted Homey, re-installed Homey, restarted my modem, nothing helps. The most curious is that everytime I start Homey I get this green Android logo.

It appears within my Homey Pro '23. When I switch to my Homey Pro 16-19, it’s a lesser problem!

The latest app/devices that I added were google minis as Chromecast. But I also deleted them 5 mins ago. Restarted Homey…no effect.

By the way, it started some days ago when I added a few Klik aan Klik uit devices. Now almost every day Klik aan Klik uit is not working and performance of Homey is lousy.

Are those connected maybe?

If I had to split this in multiple issues, I will.

Thanks upfront for thinking with me.


Which version of the app are you using and which version on Homey?

Sometimes Klik Aan Klik Uit devices can get very chatty when running out of battery. Try to remove the battery from one or more to see if your system rings normal again.

Hi, thx for the tip. To my knowledge no Klik aan klik out is running out of battery, but I will double check.

I have 1 device without battery power, butr it is an Aqara Temp sensor.

But I will have a look if changing some batteries on KaKu devices helps.

The latest versions. KaKu vers v7.3.2, Homey 10.0.9-rc.1

And when you remove the kaku app and restart Homey again?
What app version are you using on your phone or tablet?
Is Homey also very slow when using a pc or Mac?

Hi. I did not remove the Kaku app, for then I loose all my devices. I simply reinstalled the app from the store.

This morning, Kaku seems to work again, but that was the same yesterday. It seems like some requests are stuck and then block the rest.

BTW: My Hiomey on my uip to date Android phone is only not performing on my 23 Pro device. Not on the other two I have.

And what about this green Android logo that appears when I start the app? Any thoughts oin that?

I also informed Athom, but nowadays they have a responsetime of 3 weeks! Which company can afford that!

Thanks for thinking with me though @Mike1233

Hi all,

I’m sure there is something wrong with my Android app. I am realy puzzled why this green Android logo is appearing, when I restart the Homey app, a split second before the Homey logo is appearing.

Still performance of the app is sooooo sloooooowww. It is even worse than before the upgrade of the app.

And yes, I allready deleted and re-installed it. Restarted Wifi, router etc etc. Restarted Homey… Done it all.

I will try it on my wife’s phone, then I might eliminate the app itself :slight_smile:

Keep you posted.

Update: it works like a charm on an iPhone. MAybe I have another old Android device…

I also see that that Android logo, even just opening the Homey app on my phone, but the app is working fine here and is not sluggish.

Hi @WimS thanks for sharing! I am glad I am not the only one seeing this logo. I already feared a hack on my phone…

So either we are both hacked ;-), or it is normal. Didn’t see it before though. Again, thx 4 sharing!

To be continued…

The green logo I haven’t seen, but the app is so sluggish that it is unusable. I have to force close /restart it every time I want to use it. I am on v7.5.0 android app now, but it’s been like this since I got Homey Pro 2023 back in July. That software is piece of crap, I need to resort to Google Home to control my devices, or a pc

Hi @Geir_Skalvik I’m sorry that it doesnt’t work for you either, but I’m also glad that I’m not the only one. Did this also start somewhere this week on your side?

It worked ok the first week when I had only a few devices installed. Then when I migrated the rest of my system (some 200 devices with zigbee and z-wave) it all went bonkers, so it’s been like this since this summer

:face_with_open_eyes_and_hand_over_mouth: Terrible… At least good luck and hope there will be a swift solution!

I think I found the solution, not the cause that triggered it. Update: Sorry, didn’t work (yet) …

I was running the app in Beta mode. My son adviced me to switch to the standard mode and, alltough in the app-store I am still earmarked as beta tester, the app has his performance back.

So it is either the beta version that causes low performance on my Android device, or it was the numerous install, de-install (to try to get rid of the beta version) that did the trick.

By the way, I also got rid of the green Android logo showing up while starting!

So, no final solution. Performance still low :frowning:

Update: Athom is busy with improving the performance. There were indeed more users with this problem.

So we wait :stopwatch:

Thanks, I really hope so!

I upgraded from v6.x to v7.5.0x yesterday, I have to say the speed and responsiveness has improved. It is ‘workable’ now, albeit the flow editor is way too slow, but there’s no 30 seconds freeze anylonger.

From my point of view it’s still a frcking slow app, way slower than v6.x, but it slowly is getting quicker update by update.

You think it matters if you drive a Pro 2019 or a Pro 2023 with it?

Anyone had the chance to use both with the v7.x app? Is there a difference in speed & responsiveness?

@Peter_Kawa My experience is that my Pro 16-19 is faster. There’s a big but… I only have a few devices installed there, communicating via Homey Mesh with my Pro 23. So it’s not fair to say that Pro 16-19 is realy performing better.

Thanks, it’s true a fairly empty Homey responds way faster than a Homey configured to control all of the home.

I had also a very sluggish app, editting flows was not possible. After deleting the app cache it worked fine again. (HP2023, app version