Aeotec Smart Switch 6 not updating values

Hi Everyone,

Need some advice, I am running the latest version of Homey along with the Beta app so have been monitoring my Energy Usage which has given me some great insights!

One thing i noticed that is that my Aeotec Smart Switch units sometimes stop updating their values which throws things out of wack.

I see it more obviously with the energy monitoring as if i have my TV on it should be using around 130 or more watts but it would be at 20 watts which is standby which breaks my flows.

Also my Cat fountain as you can see in the picture it hasn’t reported for 3 days, This does NOT affect the commands sent e.g when the motion sensor detects my cats near their fountain it will still turn on the pump.
For me to get this start reporting i would need to turn the power switch off and on again and then instantly the values would update and work again for a period until it stops again.

Any help would be greatly appreciated !

Settings for my device

Maybe you have problems in the communication between Homey and your Switch.
Look at https://developer.athom.com/tools/zwave to check the connection.
Search on this site for ’ z-wave Mesh problems ’ to find commends on this.

Thanks that is a good idea i know its talking as i can still control the on off function, The next time one of them plays up i will try and see if i can get any more info from the diagnostics !

Cheers Matt

Hi,
I also have the same issue. I have 2 Aeotec smart switch 6 devices next to each other (washing machine and tumble dryer) It is always the switch of the washing machine that stops reporting the energy.
It never is 0 at that time, but always has some value. Mostly a restart of the Aeotec app fixes the problem. Every once in a while I have to cut the power to the Aeotect smart switch 6, to get it working again.

I haven’t contacted Athom yet about this. But maybe I should, now I see others have a similar issue.

1 Like

Hey Jos,
So even with the latest updates etc it happens, I found what you said fixed it which was restart the app in Homey and that then got the values updated immediately.

Hey Jos

How is your app/devices going with reporting values correctly all the time?

I am on the latest build and I still see problems each week. As you suggested if I restart the app that normally gets it going otherwise it’s a full power off and on to make it update.

Thanks !!

Hi Matt20v,

The problem still is the same. Last month only 1 of the 2 devices stopped reporting values.
I didn’t spend any time on it. I will unplug the device that gives most problems and use it for some other device to see if the issues could be caused by the device (washing machine) that is plugged into it.
In the past I have seen some very high energy spikes being reported, even when the washing machine was not in use. I have filtered these spikes in the flow (if energy being reported is too high, take no action, otherwise washing machine is in use) maybe these spikes / values are too high and cause the Aeotec app to stop reporting values.
But these are assumptions. After testing the plug for a different device, I will wrap up and report it to Athom. I did not do this yet, because I did not investigate myself first and thus could not give them enough info to investigate.

Hey Jos

Thanks for the update, The one I am concerned about is the one plugged into the TV, When in use it could be using 130W when in standby its around the 25W mark so there is a sudden jump when you turn the TV on.
You would have to be thinking its not fit for purpose if a smartpower plug cant measure power usage properly when a device is turned on lol.

Do let me know how you go with your testing, I will keep monitoring if Athom need any more info i am happy to help you provide it!

The other thing i was thinking about today is, since we both see it work again after you restart the app, Do you know if there is a way to script the app to restart automatically at midnight ?

Hi Matt20,

There is a built in function for that.

1 Like

Hey Could you upload that again the picture was blurry :frowning:

Strange, the picture looks crisp to me.
I have pasted a new screendump below.
If it still is blurry, then follow the instructions.

When --> Select card: “Date & Time” via entering “Time” in the search field.
Then --> Select: Card: “System” via the search field and select : “Restart app”.
Next you can select the “Aeotec” app via the search field

1 Like

Thanks so much Jos, Have you noticed version 4 to be working a little better ?

I was looking to see if I could do as you showed but there is no system option for me in my homey, I have a System section but nothing I can select that has anything like you showed.

See below shows of my interface,


You probably have to switch on “Poweruser” in Experiments ( More - Settings - Experiments - PowerUser )

Thanks Jan

I will turn it on and check again !

Regards