Adding an Everspring AD142-3 (UK plug) zwave dimmer

I have a zwave dimmer that works nicely with my Fibaro Home Centre 2.
Today I removed its settings from my Fibaro HC2.

However, I just can’t get it paired with my Homey using ZWave!
It’s my first Z-wave device to be associated – and i’m not clear if i’m doing it right.

I tried with add device > homey > zwave > install but then couldn’t get it to be picked up during inclusion mode.
I tried adding the Everspring app for AD142 - Homey appeared to crash the first time, then refused to add it the second time - and I got a red error message in the app.

The manual for the device.

I installed the beta version of the Everspring App from the website rather than through the phone.
This appeared to get past the red error and to a point where I was asked to press inclusion mode link button - whatever I did, Homey and the app didn’t seem to pick it up. :pensive:

I’m not sure what else to try to get this ZWave device included.

If a device will not include, also attempt to remove it (Even if you have previously removed it) using the instructions which came with the device itself. One of your previous failed attempts may have re-included it.

The only way I know to remove the device is through the other controller - delete device option.
Is there another undocumented method?

What I have noticed today is that the Fibaro HC2 controller has re-added it automatically yesterday. So HC2 can do it on it’s own, yet Homey has not been able to do anything? :thinking:

The fact that your HC2 controller is auto adding it, could be what is stopping it from being added to Homey (as its already in a controller).

They do not make Everspring AD142-3 for my country, try toggling the plug on/off 5-10 times in a row. Or Holding down the button, or toggling the button 5-10 times. There will be a way to reset its connection.

Last I can suggest you check out the other threads :

Sorted it. Turns out the HC2 has two ways to remove a device – one didn’t perform the exclude process.

One I did that I got the AD142-3 added fine.

Congratulations, you might want to tag the thread as solved, so that others who might have this problem in the future can find the solution :slight_smile: