Actions from the app get long delays to execute

I just transferred from my old 2019 to the new 2023 Homey

Most everything is now working ok, but I have issues with one button. The flow works as it should if I trigger it from the website environment. The trigger from both the button on the wall as from the android app get enormous delays. often it take 30-60 seconds and then a number of the buttons happen at once (almost like the tiggers are stored in memory and then quickly executed one by one.

I also often get to see nework request failed issues in the app

The set up:

in the wall a Tuya dual switch connected to a push button
on the other side of the room, the lights are connected to an eco dimmer
The flow connects these to together, but picking up the trigger from the tuya and turning on the eco-dims

This did work, but now it does not.
I did a PTP, reboot, and a longer wait, but no success.

Anything I can do?

Search the forum, you’re not the only one.

Ok, that was the first thing I did. unfortunately it then seems I did not use the correct key words. can you please point me to the right discussion?

So, Went through many different threads, and none come close to my issue, and reading back, maybe not completely correct:

If I press the play button to trigger the below flow it works ok from the website environment:

However if I try to trigger it by turning on the device:

it takes for ever to start running the flow.

So it seems not so much the flow itself as the initial device triggering. and it doesn’t matter if I trigger the device from the app, the website or pressing it on physically…

All other devices in house run normally

I already replaced it for an other tuya 2 channel dimmer, will now also try to replace it with a two channel switch (if I can find one)

Okay, so that’s indeed a different issue.

When you turn on the device from Homey, does the actual device turn on immediately, or does that also take a long time? I’m trying to find out if the problem is with the actual device, or with the trigger just being slow.

the button turns lightly gray immediately, the small icon depicting that the light is on only turns when the rest of the flow is actually completed and the other light turn on.

Checking it now again, and the flow takes 15 seconds, and I get a timeout warning (eventhough the flow does get completed eventually)

I don’t understand the situation?

You have a dimmer switch that you want to use as a trigger to turn on/off other devices, correct? Are there any devices connected to that switch at all? Or does it just serve as a “switch input”?

You can trigger the switch in two ways:

  • on the device itself
  • from Homey

Is the flow trigger delayed in both cases?

Have you tried a simple flow that triggers on the switch being turned on/off to send a push notification? That’s how you can test how fast Homey reacts to the switch being turned on/off.

It just serves as a switch input (and yes incorrectly using a dimmer iso a tuya 2 gang switch, as I didn’t have one lying around). if that is what is causing this, then I know what to do :wink:

and yes, its delayed in both cases.

Will try some simple triggers first and see the speed of Homey, when I get back home.
I also have a 1 gang switch which I will also use in this flow to see if it is the dimmer

Depending on the type of device, it may actually need having a load connected to it to work properly.

step 1 done, no success:

very simple flow:
same result. So indeed could be that it needs a load.

will try second step by replacing it with a 1 gang switch. I know that works, as I have that in a different flow working already

So tried 3 different dual dimmers, and none work as they should (so looks like a hardware issue)

Tried a single channel switch, and that works as intended with the speed as intended.

conclusion, either 3 faulty dimmers, or dimmers need a load to work reliably.

for now case closed, and thanks @robertklep for your help in asking the questions and guiding me

Instead of an actual load, a bypass might be sufficient.

Thanks Robert, have one lying around. currently working with the single switches, so going to keep it in, but will remember this for the next time, thanks!