Zigbee stability lacking in my HP23 setup - need some tips

Dear Homey Community,

I cannot get my Zigbee network to operate in a stable way. This started already with the HP19 that I started using last year, therefor I updated to the HP23 this month. I completely reinstalled the Zigbee network. Looking for insights and tips.

Setup Zigbee network:
-13 Icasa AC Dimmers (Router),
6 on ground floor, 4 on 1st floor, 2 on 2nd floor
-2 Robsmart LED dimmers (Router),
2 on ground floor
-3 Aeotec Range Extender (Router).
1 on every floor in the hallway
-Homey Pro 23 coordinator
centrally on 1st floor (LAN connected)

Installed in an 160m2 house with three floors (base, 1st and 2nd). The devices are evenly spread. It is an old house, but has thin layer concrete floors with groundheating (vloerverwarming) on every floor. Also there is added (rockwool) insulation in the walls and ceilings.

Operating currently
I have to reboot Homey multiple times each day to be able to interact with the Zigbee network. After restarten Homey I can perform 1 or 2 commands (flow with zigbee, or individual devices) and than the Zigbee network goes down again. Down meaning that the Devices are non responsive from the app and flows with Zigbee devices involved fail to work. They tend to work perfectly shortly after a reboot.

Than after a while it stops working. I can deactivate for example and Icasa dimmer. It shows deactivated in the app, but the light is still on. Sometimes the light will go off, but than after 10 minutes, not instant.

Troubleshooting I tried:
After restarting Homey everything seems to work fine. Also, in the Homey developer portal I can ping all devices and they get a response. This stops after a moment or after a few commands (flows/devices).

I noted that the Icasa app seems to put a lot of weight on the operating system.

I have tried and tested with completely shutting off the 2.4ghz wifi network. This had no positive effect.

I have reset the Zigbee network towards the 15, 20 and now 25 channel, as far away from Wifi, no effect

What do you advise?

  • Add more repeaters, such as the Aeotec? Which do you advise?
  • Is something broke in the Homey, and maybe try another HP23?
  • Do you have any suggestions to make this work?

Thank you very much in advance

What do you see shortly after restart in the bottom part of https://tools.developer.homey.app/tools/zigbee ? Version and Current command ? What do you see there after it stops working ?

  • try PTP (not sure you have tried)
  • another power source (do you have the “2nd” generation already ? Do you see any undervoltage issues on Homey Developer Tools ?
  • update to the latest firmware
  • try to do (cloud) backup → reset (via USB) → and restore
  • if all fails, please contact Athom support linking this thread and send them also system diag. you will create on Homey Developer Tools, shortly after restart and when it starts failing
1 Like

What the CPU does and what do you see in the insights for this app - CPU and mem ?

1 Like

This is shown shortly after restarting:

System Information
Current Command
Firmware Version

Is the Same for when it stops working.

Thanks for the suggestions.

  • PTP I have tried, no luck. Tried from 10mins up to 1 hour / 24 hours reboot.

  • Power source the tools say the following:
    Can you read this? I expect since false that this is not the case. My HP is one month old and I use the internet extension.

  • Latest firmware is on HP

  • backup was done, as well as full re-setup

Thanks anyway, I contacted Athom

RSS 72.4MB
PSS well above 30mb, now 37mb
CPU flatlines on zero and shoots to ±10% with any interaction

After i restart the specific app from Icasa the PSS lowers to ±20mb but gradually goes up. Even after deleting half of the Icasa devices still around the same level

Yeah, I mean Insights…graphs, eg. for past hour or so… but based on explanation, it’s stable

1 Like

It’s OKay

What is the version you are on ? You can try to enable experimental updates…there was Zigbee firmware update, if I’m not mistaken.

1 Like

I see, I am on 10.2.1. How do I activate this experimental version? Thanks

  • edit: nevermind, found it and now downloading v10.3.0-rc.7

After removing 5 icasa devices I now have a stable network for 2 hours. Let’s see how long this goes. Either I cannot add additional icasa or no additional Zigbee at all. Responsiveness is perfect now as wel.

All dashboarding in de developer portal and app usages remain the same.

I have a similar experience and I have informed Athom and is now waiting for a reply. Did you get this error message?