Z-wave mesh question


I recently purchased a few thermostatic valves (Eurotronic Spirits) which act as z-wave plus slaves (FLIRS to be exact). One of them doesn’t respond properly to Homey and I think it’s out of range (or at least, there is a lot of stuff between Homey and the valve (walls, furnature, etc). My idea was to put a z-wave routing slave (if that’s the proper term) somewhere halfway. I don’t have any practical use for something at the moment, but I figured I could just put a smart plug in between one of my appliances, which may be something I could use anyway at one point in the future.

I was looking at Fibaro Wall Plug Type F for this purpose or maybe preferably a powerstrip (Stekkerdoos in Dutch) if anyone knows where I can find one.

My question is. Will this functionally work (given that the distance and interference will be acceptable enough)? Can/will/should any z-wave slave able to talk through a routing-slave towards Homey?

Powered z-wave devices should function as extenders in the network, so yes

Correct @Toon_Vos. But be aware that there is alot of quality difference. So for instance the neo coolcam powered devices have a really crappy range so they can be used as extenders but won’t help much (depends on the situation ofcourse)

Thanks for the replies so far.
It appears that not ALL powered z-wave units also function as an extender if I look at this product for example. Or at least. The device doesn’t have the Role (which is lister in this document on page 20: https://www.silabs.com/documents/login/miscellaneous/SDS11846-Z-Wave-Plus-Role-Type-Specification.pdf)

Whereas these products do seem to have that feature:

At any rate. What kind of experience do people have with the Fibaro wall plug?

I have five Powernode 6 running and they do work as relay, no doubt - but since they are quite old (that is: z-wave, not z-wave plus) they do of course not work as relay for z-wave plus devices…

The two other devices you mention are both certified z-wave plus and will relay everything in the same network…

Could have been that simple - but then you mention FLIRS - which is a bit complicated and at present Homey somehow doesn’t handle this very well (Search “FLIRS” and “MarcoRuiter” here, on Slack or on GitHub for thorough explanations)

Hi, final update:
I purchased a few Fibaro Wall plug F’s (primarily for the purpose mentioned above). I did some testing. I put one on the far side of my house and now the valve functions flawlessly. (the wall plug is about 40% further away than the homey sphere but still it functions better. So the range of homey isn’t very impressive in comparison to the wall plug (at least when it comes to interference from walls etc)

For those who care to know:
The homey sphere is about 4-5 metres from the valve (with some walls/furniture in between) and the wall plug is about 9-10 metres from the valve (with the same walls/furniture between them). If I look in a straight line, the homey-sphere is approximately in the direct line between the wall plug and the valve.

Thanks again for all the quick and informational replies!! :slight_smile:

Morning, I basically have the same problem. I have three floors in my house. Homey sits close to the ceiling in the middel of the ground floor. I have 2 thermostatic valves and 3 smoke sensors. All Z-wave plus. The thermostat on the second floor and sometimes the smoke sensors too are unreachable according the zwave table. So I bought the Fibaro Dimmer 2 which is located in the middle between the homey and the thermostat on the second floor. This should function as a router and make it possible for the thermostat to route through the dimmer to the homey. I already switched off the Homey for 15 minutes, hoping the zwave table would be build again, but no luck so far. Any tips how to force a mesh network?


As i can see you have only one powered device, the Fibaro Dimmer. The strange thing is that not any device is using it as a path to Homey. So either it suffers from bad reception because it is a built in device or maybe it doesn’t act as a repeater at all.
Like @RoyWissenburg says, you should place at least 3 repeaters, one for each floor. So i advice you to buy a 3 or 4 Neo Coolcam plugs via AliExpress for around 18-21 euro a piece and place them at strategic points on every floor.
Like @ArnoP mentions hereafter, be sure to buy the Z-wave EU version, not for another continent or the WiFi ones.

Or just at one of the well-known Dutch shops, since it looks Fred is also from NL. Price is the same with just under €20.

Edit: Oops, didn’t look good enough and looked at the wifi plug. Zwave plug is indeed a lot more expensive…:zipper_mouth_face:

1 Like

Thx for the replies guys. I bought the fibaro also because its functional. Its the only hard-wired device, rest is battery. I don’t have that many devices that need controlling on the first floor so I hoped that the fibaro would have functioned as a hub for the second floor. Not that lucky I guess. Will have a look at the neo coolcam plugs. I read different stories about the repeater functions of those. Which repeater/router/device would be best as a main function to provide better coverage?

Will buy the cool cams, see how it works out.

I also have Aqara Zigbee devices and many Hue lights. I still use the bridge instead of the direct zigbee option. Any way to make use of the zigbee mesh trough the hue lights? :wink:

Nope. Every controller has its own separate mesh.

1 Like

Of you connect them to Homey yes

“Force mesh”, just click the options for a node (far right side, 3-dots symbol), and chose heal. That resets the learned route and a new one will be learned next with the next signal.

I have an Aeotec door sensor that I cannot get to communicate with Homey. In the attached picture it is Margs Door device 44. Devices 32 and 48 are Aeotec Smartswitch 6 devices and are about 10 metres away from sensor 44 and about 6 to 8 metres away from Homey.
I have been trying to reset the mesh network so that 44 networks via 32 and/or 48 but have been unsuccessful. Whenever I try to “Heal” the network it just comes back with a Neighbour Update Failed error.
I must admit I really don’t understand mesh networking, but it seems strange that 44 wants to go direct to Homey, yet 32 meshes with 11 which is the furthest distance between any of my sensors.

It says “last route: unknown” so it isn’t trying to connect directly, it just doesn’t know a route.
Put it closer to Homey (or other way around) and see if it then works, if so then the range is just too big/something is jamming/absorbing the signal/no powered device has the door sensor in it neighbouring table (devices that are nearby) which is what “heal” does, update this table in mains powered devices

I also have a device with “last route: unknown” and it still works.
I would also follow Caseda’s suggestions and remember to wake up the sensor.

By the way: The routes are not always logically structured and they often make no sense, at least not for me.

Thanks, it just doesnt seem to want to heal. If I get homey close it does communicate OK.

I think I will try removing and re-adding it.

As a last resort I changed the battery. Had to change it twice but it now works. Strangely the developer dashboard still shows it as unreachable, and the Test command and the Heal command still fail. Still its working now and has a decent mesh table with some of my powered devices.

But in the screenshot there is another sensor.
If sensor 44 works now I’d keep it like this and observe it for a while.