Z-wave issue items turns on with out active flow

Lately items in the z-wave network turns it self on with out any flows has turn them on. I have Aeotec heavy duty that controll my vvb (water heater) heatit controll z-dim and z-water that controls z-temp2. Z-wather is the item that I installed latest, but every thing worked fine one month before every item seem to go on the same time with out a flow has activated them. Lights can go on in the night and heavy duty gives power to the heater when it is supposed to be off. In the homey app every item that is supposed to be off is the color gray and seem off, but the light is on in the room and heavy duty is using W and A.

Do any one have any ideas what I can do?

Install Flow Checker if you didn’t already.

  • Disable the zwave app(s) involved.
  • After a while, Flow Checker will report which flows are used with zwave devices.
  • This way, maybe you’ll discover flow(s) you might have overlooked.

But, as you say, if the device tiles are off / greyed out, a flow doesn’t look like being the cause.
What do the devices logs say?
Longpress a device tile, hit the icon at the bottom right.

Zwave devices can contol other zwave devices without Homey, but if that happens, the device tiles on Homey should just show their current On Off status…

I think you’d better start over with these zwave devices.
Reset them to defaults (if possible)
Remove them from Homey
Pair them again
Fix flows manually (there’s a “fix your flows” script, but I’m afraid you also “fix” an error back into your flows.

Also make sure there’s no signal issue.

1 Like

And other broken, unused (This flow was startet…) flows. So it might be confusing.

If you long press on the device tile and switch to this menu…
…then all the flows are listed where the device performs an action, e.g. turns on/off. In my opinion, this should be enough to find relevant flows and deactivate them.

This function (association) must be configured manually. So it’s not possible for this function to be activated suddenly or accidentally.
But if you @Andre_Kleppe_Risvold have configured any associations, then remove them and test if the problems still occur.

Before you remove all devices and then add them again, I would suggest to check first if the devices may have problems with communication (Developer Tools → Z-Wave (3 points → Test)).
With the command Send Basic On/Off you can also test, if the devices switching on/off correctly.

I can’t really explain the behavior, but because it worked for a time and then suddenly these problems occurred, I could well imagine that a Z-Wave device is broken and/or interfering frequencies are there, e.g. due to a defective power supply.

True, but I assume the user can check things for himself. No tool app is understood right away, one has to read, try, test things out.
I can’t explain the whole app everytime I hint to a tool what is probably very useful.
And when the user doesn’t understand something, he can always ask, right?