Homey Community Forum

Z-wave devices suddenly unstable with "Something went wrong" error

I have recently experienced unstability with my z-wave thermostats. Sometimes they are changing temp and sometimes not. Its been two months since I set up everything and it looks to me like they have been working properly until a few days ago. Testing flow with z-wave devices shows error “Something went wrong”. In the developers tool it looks like everyting is reachable and is working OK when I try to test them there. Any ideas what this could be? I have tried to restart Homey several times, but I would prefer not to reconfigure all the z-wave devices if I can.


Which app? Fibaro?

Do you have other Z-Wave repeater in your Z-Wave mesh?
NodeID 18 has definitely a connection problem.

Why do you think it’s the Fibaro app? Fibaro does not have electric powered thermostats.

Nothing was specified by the TS.
Fibaro has radiator thermostats (but these aren’t mains powered probably) and the app was updated last week.
There were other errors reported elsewhere.
That’s why I asked if it’s Fibaro :wink::upside_down_face:

All thermostats is Namron a Norwegian company I think. They have been stable for as long as I have had them until recently.

Did you changed something? Homey Firmware? Namron App?
Did you tried already a PTP? Did you changed the Homey power supply (> 2 A)?

I have not changed anything. All is the same, except that Homey has been automatically updated. The Namron app is the same.

So please do a PTP first and give Homey some time to rebuild the Z-Wave mesh.

Thanks, I unplugged it and let it rest for about 15 minuttes before I connected it to power again. Now everything responds as it did before when I change something. But I still get the same errors when pushing the “Test” button on a flow, and also the developer tools say some of the nodes are unreachable. Even though everything responds as it should when I try it…strange…

Can you share a new screenshot from the developer page?

The strange thing is that they are always “reachable” if I try “Test” like I did with Node 25.

Looks like you mostly have battery operated devices?Homey’s range isn’t that big (7 - 10 meters in direct sight, so nothing in between like walls and floors).
That makes no stable mesh network at all to increase this range. (Only (mains) powered devices can route other devices between devices and Homey).

Edit: I need to read better :see_no_evil:

Also looking at the amount of unknown nodes, you had a lot of failed inclusions, probably also because of a too big of a distance, I guess you tried to add them from where they will be mounted?

Doesn’t seem a lot of powered devices if you have a big-ish house to have a stable mesh network, probably a small interference occured throwing of the network, making most devices stop responding to Homey.

Yes, I tried to add them where mounted, but I had to move Homey around closer to each of them to get them connected. But I kind of added them randomly. The distance between them could maybe be an issue. I have no clue what could cause an interference in the house as there is not so much stuff going around here I think. Should I reset everything and redo all of it? Should the order which I add them be considered?

Thx for sharing the screenshots.
Z-Wave devices needed to be included just few cm far away from Homey. Homey doesn’t support „Network Wide Inclusion“ (NWI).

What can cause range problems? There are a lot of things that can cause range problems like other electrical devices, metal frames in the walls and so on.

Rebuilding the network does not necessarily mean that the network will work properly afterwards (due to the possible interference factors mentioned above and because there may be too few devices in too large area).
But in the end, you can only try it out. I would start first with the devices that are installed closest to Homey. And then continue further.
Battery powered devices I would add last.

Thank you very much for your help. What I have tried first is to move Homey to another location in the house to see if that can help. But there are a couple of things I find odd when looking closer in the Developer Tools:

  1. Even though placed very close to Homey with direct access and no obstructions it seems like some of the node routes are going to devices far away from Homey and then back to the closer device. That makes no sense to me.
  2. Some of the nodes says “unreachable”, but every time I press “Test” it always works. I have yet to see it not working.
  1. The routes are not always logical, I don’t know why.
  2. I’m definitely not a Z-Wave expert but maybe the devices were not properly included, due to the distance while the inclusion.

Did you already tried to “Heal” the nodes/routes? Just klick on the 3 dots on the right side and then on “Heal”. This will force the device to search for a new route.

Rem: When I do this on a Windows-PC, I have to refresh the page (F5) to see the new routes.

Yes, I have tried it several times. Does not seem to make much of a difference.