Xiaomi Home - Get Room ID

I managed to add my Xiaomi vacuum to my Homey devices, and I noticed that I can tell it to go to a specific room. I need to give Homey the room ID, but I have no idea how to find that in my Xiaomi app…

How can I extract that?

Do you use it with the Roborock app?
If so, https://community.homey.app/t/app-pro-roborock-vacuum-cleaners/49521

I use the Xiaomi Home app. I have a Dreame Z10Pro, which is not directly recognized but apparently holds the same functions as the other Dreame vacuums.

Also, I cannot use the Roborock app because I have a Homey Pro (early 2023) which is not compatible currently

I think the first room ID is 16, and then +1, so the 2nd room is 17 etc

I thought so indeed when doing a little bit of Googling, but it doesn’t seem to work.

At this point I’m not sure whether the function itself “Send vacuum cleaner to clean room” doesn’t work or the ID number is wrong, or if the Dreame Z10 pro isn’t yet fully compatible…

To be sure, am I correct to assume that this function doesn’t need any previous functions to run first? I thought maybe executing the “Turn on” function first would be necessary but that isn’t the case either.

Just setup a test for you, with my Roborck S7, works perfectly. First room is 16, next one 17, 18, 19 etc.
You define a room in the Xiaomi phone app.


It could be that a Dreame Z10 doesn’t support this feature, but you could test that through the Xiaomi phone app, can you send it to a specific room there?

Indeed my Xiaomi phone app is all ready to go, I have the map of my home properly listed and I am indeed able to send my Dreame to a specific room - all of it works fully in the Xiaomi app so that doesn’t seem to be the problem…

In that case I think it should work from Homey too, but maybe it’s different ID’s for the rooms, so you could play around with that maybe?

I tried manually putting ID numbers from 0 all the way to 100 and above, and still no luck :frowning:

1 Like

I can’t really test it for you, since I don’t have a Dreame, or see your logs from the Homey app, The room ID’s will probably be in there, so I think the easiest would be to post your question here, or ask the developer (@Phuturist ) if he can figure it out based on your diagnostic logs.

Hope you can figure it out :+1:

1 Like

Hello, do you find a solution for this? I have same
Problem with my dreame.
Greetings Hanno

I’m also trying the same with a Dreame L10s Ultra. If i try to run the card I get the error:
“Unexpected token o in JSON at position 1”.

Commands like start cleaning or return to dock are working OK.

Bei mir das gleiche

Still no solution :frowning:

Apparently, there is more to it than just setting an ID on the Dreame, I don’t own one, s cannot check. This website gives information for Home Assistant and using the dream Room ID’s. Also, please ask questions about the Xiaomi app here, you are more likely to get an answer from the Developer.

Any success?
I have a Xiaomi S10+, and finally today got the token and added it with Adv. Dreame Vac. in Xiaomi Homey app.
I have tried SO many room id’s… No luck… All others work perfectly, but this little isue… The most usefull one - I can’t find.

Nope still not…

Online documentation on this is horrible. Indeed the best way to get answers is to setup a connection with Home Assistant and somehow make it work. But for people like me who such at the more low-level smart home stuff I wouldn’t know how to make it work.
If only someone could just give us the format for the Room ID’s…

1 Like

Same for me!

I’m using Home Assistant for cleaning certain rooms. The description is already a few days old but setting up worked for me just fine: Home Assistant Anleitung how to... Roborock einzelnen Raum saugen lassen - smarterkram.de

Hope this helps anyone else!

1 Like

Hi Bernd…

Thanks, but I have no HA. Only a Homey pro 2019.

Would you know if I can script this directly in Homey?