Wiz Smart

Hi, I just got two Wiz bulbs (The E14 candles), connected them with the Wiz app, Enabled Homey, got the link code, put it in the Homey app, close the window as it prompts and then it hangs on the “log in on website” loading screen.
It doesn’t seem to go through the Homey connection.
If I try it again, I need a new link code and it goes as mentioned before…
Any ideas on why this happens?..

2 Likes

No matter how much I try, the official app doesn’t let me use it…
I did, however, find out how to get your app to work Jan-Ivar! It works like a charm with my Tradfri wireless dimmers, to turn the lights on and off! Thank you so much for sharing.
I did read the posted dimming ‘issue’ on github and found myself handling the same issue, lol.
Do you think you are going to be able to figure out how to use plus and minus dimming? Would be awesome.

I may try to activate the official app again later this weekend, but for now I’m pretty happy :slight_smile:

[Edit]
Btw, I just looked it up and I’m using the E14 color candles 8718699787097.
Maybe you’d want to know they also work.

Thanks for the nice feedback. Theoretically, most of the Wiz bulbs should work as the different bulbs have the same api syntax. It just seems that some have more features than others.

For any other users experiencing issues during WiZ authorization, you can try the following:

  1. Disable the Homey integration in the WiZ app
  2. Make sure all WiZ devices are removed from your Homey
  3. Re-enable the Homey integration in the WiZ app and make sure to copy the new link code now. This is the most important step.
  4. Try to link your WiZ device in the Homey app with the code you’ve already copied, so you do not need to exit the app to setup the connection.

It looks like it a bug when using multitasking on your phone. If this solves the issue, please share some details about your phone (OS version) and the Homey app version, so hopefully this can be solved by Athom in the future.

Yep, that fixes it. Ty!

Samsung Galaxy s10+
Android 11
Homey 7.2.0

anyone know if/or have tried the WIZ wall plug with the app?

Unfortunately the WiZ Cloud API does not support the wall plug at this time, so the Homey app is unable to support it.

I have updated the unofficial WIZ app om the community store. It now support the ceiling lamps (flat plafond) using only the local network.

If you mean Wiz SmartPlug then I am now testing the interface to this one these days. I expect to post it on the Homey Community Store in the near future as version 2.5.0 of the WizBulbs app.

Update 18/5 2022.
A new version of the app i the Community Store is out. The app directly controls bulbs, plafond lamps and the smart plug over local WiFi.