Virtual device: SVG requirements

I’m trying to create a virtual device that implements a modus. I want the device to show a lock on its button in the dashboards. For this, apparently you can add an SVG during the creation of the device.

(Note: the one in this screenshot did not work…)

I tried the SVG’s from GitHub - athombv/homey-vectors-public: Developers can request vector icons for an Homey App here and these work, but when I try to create one myself or download a free lock.svg, they don’t show up in the button.

So, what are the requirements for an SVG icon?

This might be a bug in the web app. Have you tried viewing the icons on mobile?

I first tried online .svg icons, some 10% were ok. Until I discovered the Athom icon base, and I’m happy with that :wink: Maybe you can drop the icon creator a note?

Yeah, tried them in web, dashboard and mobile. Doesn’t make a difference.

I might as well try that yeah, but I would really like to know what the requirements are. It’s a bit stupid these aren’t documented.

Resolutions for the app image:

  • Small 250 x 175

  • Large 500 x 350

  • XLarge 1000 x 700

Resolutions for the driver images:

  • Small 75 x 75

  • Large 500 x 500

  • XLarge 1000 x 1000

1 Like

I can 100% confirm you will never see the uploaded icon on the web app without having viewed the device first on mobile. Why these icons from the GitHub link work is because these are official icons that have already been used before. This means they are already available on the Athom CDN.

I’m not sure what you mean to say, Jero, but this works on web app. I did nothing on my mobile app with this.


Then that icon is already known to the CDN.

1 Like

The only requirement I know of is they have to be black and white (no grey).

I can also confirm that @Jero is correct, they will need to be viewed in the mobile app before the web app will display them. The web app requires a jpg that is generated by the mobile app.

1 Like

Thanks, that piece of information was missing from @Jero 's remark. I tried the mobile app on once or twice, didn’t work (probably due to non B/W SVG), than didn’t bother with the mobile app anymore. It works now - I’ve got my SVG visible in the button. Thanks!