Upgrade from 1.5.13 to 2.x

So, I finally decided to upgrade to update from 1.5.13 to 2.x

But I can’t find the update button anywhere… this does not help: https://support.athom.com/hc/nl/articles/360015540073-Hoe-installeer-ik-de-Homey-v2-0-update-

There just is no button…


Searched the forums but to no avail.
Tried rebooting it in the hope the button would show up… does not help

Also tried from the 2.4 app… same message…no update available

So, how do I upgrade my 1.5.3 to 2.x ?

Never done it myself, but as I understood reading the forum, you need to install the Homey app on your phone, where there would be a option to update your Homey.


See the instructions at:

To install firmware version 2.0 on your Homey, you first need to install the new mobile app on your smartphone. To do so, search for and install the Homey App from the Google Play Store (Android) or Apple iTunes (iOS).

Select your Homey

If you have more than one Homey linked to your account, select the Homey you want to update to Homey v2.0.

Press the install button and wait patiently while Homey downloads and installs the update. The LED Ring will show blue, orange, purple and orange again during the update.

All done


Like I said, I tried this from the app:

There is no upgrade

Plz delete ur insights first!!
Don’t push any update button before u deleted the insights!!!

You need to install the new Homey app. This app will let you upgrade to Homey2.0.

1 Like

The mobile app that is!

That’s not the NEW app. Read the instructions carefully.
If the new app connects to an old version of Homey it asks (warns) you that you have to upgrade to a newer firmware and ask if you want to do that.

Okay… turns out I still had the beta app of 2.0… but that turns up at the play store as the same as the current…

Re-installed the app, and all is fine now.

And when I you search for the homey app in the play store, it just displays: Installed

Just perfect… update went fine… I saw all my devices … for one minute…

Now all the app displays is: an unknown error occured

Okay. fixed it all. Documenting it here for the next unlucky fellow

So I uninstalled the app, and reinstalled it… from the app store I launched it and updated homey… all went fine… devices are there… all honky dory.

Minutes later started the app again and everything was broken again…

Turns out that the beta app was still on my device… I’m using a custom launcher, and that pointed to the beta version.

So this beta version nowhere shows up in the store list installed apps (also not under beta) you have to uninstall it using settings -> apps -> homey -> uninstall.

Did you even click on the link that Alcor provided? That points you directly to the correct app to install, so no mistake or mixup possible…

Did you even read my comment?

My launcher was pointing to the beta app (which cannot be seen in any play store screen)
So, a mixup IS POSSIBLE…

Yes i did. And that should be impossible if you really uninstalled it. And re-installation the wrong app would also have been impossible if it isn’t visible in the app store.
By clicking the link in the installation guide you would have installed the correct app straightaway.
But it’s working now, so :+1:

The problem is that the launcher link pointed to the old beta version, I guess you have an iPhone, where this indeed is not possible… on Andriod it is.

I’m trying to be helpful here for others that might experience the same, I suggest you stop being a smart ass about it.

Omfg, did the heat get you? Better cool off dude.
And to answer your question (i am raised to answer a question nicely and politely):
No, i have an android phone. And if i uninstall something, it is gone. No matter what launcher i have. Sorry for that.

By the way, you never did answer my first question. So i have to assume you didn’t.

I’ll be the wise one here…

So did 4 other ppl for you including a very clear tutorial…
Didn’t see a “thank you”…

1 Like