Unstable lights

I have been a SmartThings user for a little while, but just recently decided to jump over to Homey Pro. I just connected it yesterday, and was curious to test it out.

At first I was pleasantly surprised by the user-friendly device management and flow creation, but then I was a bit bummed when I found that I seem to have the same issue that was the main reason I left SmartThings: Stability when turning on/off a group of lights: I have a mix of Philips Hue bulbs, Fibaro Dimmer 2 and some Fibaro and Osram wall plugs. When I first created a flow that was setting a Hue scene it worked flawlessly: Boom, and all lights were on/off. Then I added more of my Fibaro dimmers and Wall plugs, and suddenly when I tested it I noticed that some of the lights were really slow to react, and sometimes one of the lights remained in the wrong state (on or off).

For me this is super annoying: If I have to wait for 5-10 seconds next to the wall switch to make sure all lights are on/off and then potentially run the scene once more to fix the one light that was “hanging”, I would rather my house was not “smart” at all. My assumption is that most people would agree with this, so I find it hard to believe that this is just something you are supposed to have to live with.

Can someone please help to shed some light on this, and maybe point me in the right direction on what I can do to try to improve this? I also want to understand what exactly is happening here: Is Homey just broadcasting a signal and then not waiting for the device to somehow confirm that it executed the action it was asked to do, or is it more likely that the device reports incorrectly back to Homey so that Homey believes that the action was executed?

I am so happy with the rest of my experience with Homey, so I would be really frustrated if this was just something I would have to live with. For me, stability and speed is first-priority in the smart home, so I want to get to the bottom of this before I give up. The devices I tested was in the same room as the Homey, so none of the devices should have been outside of network range. When I turn one and one light on/off it always seem to react almost instantly, so this only seems to be an issue with trying to turn of multiple devices at the same time.

Small follow-up: If you want to trigger a scene from many different flows, are you then just supposed to create one flow, and then trigger this flow from the other flows you make? So that the original flow is the “scene” that you reuse? Just feels a bit strange to me, coming from SmartThings, because a flow is associated to a trigger, which I don’t feel that a scene should be. A scene should just be a combination of device states, as I see it.

1 Like

I am having the exact same issue. I have used Zipato (Zipatile) until last week, when I bought a Homey as I experienced stability issues with the Zipatile controller (which was more offline than online). I have quite a simple set-up, with 23 Z-Wave devices (of which 10 are Fibaro Dimmer 2) and a few 433 mHZ devices. Setting up was a breeze, as well as the connection to Amazon Alexa.

But then, when starting to use it, the enthusiasm faded. A flow with 6 groups of lights in it (5 Fibaro Dimmer 2 and 1 Everspring Wall Plug) randomly executes a few, one or rarely all devices. No logic, it’s just guessing what will work, sometimes with huge (unacceptable) delays of up to 10 seconds. I’ve tried moving Homey around, healing Z-Wave nodes, adapting flows, having Alexa directly control all devices, but it doesn’t help. I’ve also added delays to the different cards in the flows, no results.

I now have a case open with Athom support, but unfortunately, the instructions provided (although response is good - Thanks Athom, at least that’s better than with Zipato!) don’t help. Like this, Homey is completely useless to me, just like Knut mentions stability and speed is my number one requirement as well. Homey is really great in terms of UX, but in the end, if it doesn’t work, it’s no use at all.

When the Zipato controller was on-line, I never ever experienced any delays or issues with any Z-Wave device. Now it’s a complete mess, while no Z-Wave devices have changed location, and they have all been properly excluded/included. Simple logic makes me believe Homey is the issue…

Anyone?

1 Like

I have exactly the same issue.

In one of my flows I have three Philips Hue devices and four Fibaro v2 dimmers. Randomly one of the Fibaro dimmers are not executing the command configured in the flow. For me this started some weeks ago.

The latest alpha of the group App (2.4.202) will do an additional check (on top of what Homey & Zwave - should be doing) and resend a failed command.

https://apps.athom.com/app/com.swttt.devicegroups

But like all things in life, there is always a compromise - that being speed. I don’t know that something has failed until Homey tells me (which with Fibaro dual switches takes 3 seconds).

Send me your emails address via PM and ill add you to the alpha to test, please just keep in mind devices failing, delays etc are not caused by the group app.

Thanks, I’ll do that! Athom Support has now for 1.5 week stopped replying to the (still open) support ticket, so I guess they have given up as well. Let’s see if this helps, otherwise, its’ bye bye Homey…

Did anyone got a solution for this issue?

I’ve been using Homey for over a year now, and recently start experiencing similar issues. Some devices that sometimes fail to turn off (in my case), because they are send as “bulk”.
I do have a sort of a backup flow that turns off everything at night “just to be sure” but it shouldn’t be needed.

I mainly wondering whether this is a “Homey” issue or a “Z-Wave” issue. Because Knut was also mentioning he experienced the same issues with SmartThings and since I only experience the issues with Z-Wave controlled devices (but to be fare of the aprox 15-20 (mainly Qubino) devices (lights) I only have about 3 non-Z-Wave devices).

Although I have a variaity of device brands (Qubino, CoolCam, Fibaro, Philips, 433mHz). My experience is that it is mainly the Qubino devices that fail (I don’t remember others failing), but as mentioned before that could also be coincidence, because the Qubino’s are also the majority of the devices I have (about 75%).

In my case I’m sure that the network range can’t be an issue because one of the switches that failed me recently is within less then a meter from Homey.

I am stil experiencing this every now and then. Usually it’s OK (but sometimes slow). Other times it leaves a random light on. Super annoying… Haven’t still introduced any retry mechanism. That would be the last resort, and I think the platform itself should be able to handle retrys behind the scenes

I’m having lots of problems like this too - do you think Homey devs are aware of all of these problems ? Surely controlling a bunch of lights reliably is a standard requirement? :-/

Have same issue. Got my homey before Christmas and have been testing some stuff.
*z-wave is useless at all. I have 1 aotec MultiSensor and the range is like 5 meters max. Useless.
*zigbee range is better. But have same issue when using motion sensors for more light bulbs. It takes way to long time. When i go down to cellar it uses 4 seconds to turn on the lamp (Flow with 10 ikea trådfri lamps). It would be Quicker to turn on lamp manually…

I am thinking of buying Phillips hue bridge instead for light control. But i dont like that this would mean that i need one more zigbee Network… When homey is suppose to do the same thing.

Only reason i might keep homey is for temperature and Humidity sensors id like to keep. But if i remove lamps to Phillips hue i guess i lose the mesh connection from lamps to humidity sensors… Annoying.

I feel tricked when homey cost quite alot and dont work as intended.

Also WiFi connection seems more unstable after i got homey. Maybe they interfere with another.

Any update on this? Zwave is useless for me. I bought Homey pro 2 months ago. My domoticz controller was much faster AND stable.

Yes, for me this was fixed by putting the fibaro dimmers into “non-secure mode”. It’s a bit hacky, but there is no direct setting for this, so the clue was to delete the dimmer devices and add them again, but this time add them as a “Fibaro walli switch” , which is a device type that comes in non-secure mode by default. Everything worked as normal, but suddenly the dimmers responded much faster and much more reliable!

1 Like

Is this the only solution?

My fibaro dimmers are having the same issue after succesfully using them for the past two years.

AFAIK, with Homey firmware v7, if you re-pair non-S2 devices they will be included unsecured by default. So your issues may be resolved by just re-pairing your dimmers.

Thank you!

I have just made a workaround with 4 flows to switch on 4 fibaro lights. This works flawless and without a delay. Although it seems stupid for now this works for me.

Ofcourse the same goes for turning them off.