Unpaired Tuya Zigbee switch turns every smart plug ON / OFF!?

I’ve got a totally weird problem over here, and also looks like quite a security hole. I’ve bought a Tuya 4 switch zigbee unit, and I tried to pair it with my Deconz zigbee receiver without succeeding… But I noticed when I press the top left button once…. EVERY smart pug turns on !?!? When I press the bottom left button every smart plug turns off…. What the….

I didn’t pair it yet to anything. I tried, but deconz did not detect it, and I didn’t even add it to Homey (with Homey Deconz)… This is so weird… Also the smart pug brand does not matter. I have Innr and Ikea smart plugs, en they all turn on / off.

Some plugs aren’t even connected to flows or something.

Anybody got a clue?

It probably is paired, but not showing up in the Phoscon web interface because it doesn’t have the correct “switch” clusters (I assume On/Off). If you use the graphical interface of deCONZ itself (the one showing the Zigbee mesh), it’ll probably be shown there.

As for switching all devices: it sounds like the Aqara Opple switch, which do something similar (sending broadcast messages).

Hmmmm it seems you are right Robert… Apparently it did connect to Deconz although it said it could not detect anything… But it seems to be added as a light in the Deconz app. I have to investigate why it turns on every device.

Because it’s likely broadcast one (or more) clusters. In the deCONZ UI, press F6 (or select Edit > Destination Settings) and select all clusters of the node to see if there are any set to Broadcast. If so, change to Unicast (although I’m not sure to which address…)

If I open up the Deconz vnc select the switch node and press F6 I see this.

To be honest, I have no idea what I’m looking at. I have also no idea how to select a “cluster”. Anyhow, apparently the switch isn’t detected properly. Maybe I need to update Deconz. But I have to look into that how I do that inside a docker container, without breaking every Zigbee connection.

I can keep repeating myself: the switch is sending probably sending a broadcast message. It’s not broken, it is detected properly, and updating deCONZ very likely won’t fix it (because it’s not a bug).

The Destination Settings window only makes sense if you select a cluster on the node that represents the switch. To select a cluster, press the right-most gray button on the node:


That pops up a window with the clusters for the node. Click each one to see if the address mode changes to Broadcast (any of them) for a particular cluster.

Hmmm every cluster seem to be configured as “Unicast” (clicked and checked them all)

Perhaps there’s another mechanism that causes all lights to turn on/off. Perhaps search for similar cases at the deCONZ issue tracker: Issues · dresden-elektronik/deconz-rest-plugin · GitHub