Aqara switch H1 double

Good afternoon,
I have something strange…
I bought a aqara switch H1 button. (With battery)
When I activated the battery and pushed one of the buttons all my light went on. If I pushed it again everything went off.
I haven’t connected the switch yet to homey.
How is this possible?

And another problem is that I can’t connected him to homey for some reason. Probably because everytime it goes in connecting modus every lamp turns on…

Thank you for the information!

1 Like

Hi Jeffrey,

I have the same issue with the Aqara H1 double rocker switch. No idea how it’s possible, but I get an error while adding to Homey, the device is nowhere visible in the devices list, so it does not seem to have been added despite the error, yet when I click the button, all my lights go on/off.

So I have a switch, controlling Homey-connected Zigbee devices, without having been added, let alone configured, in Homey. I have a Homey pro 2023 and here are some devices that are turned on/off when

-Sonoff ZBMINIl2 (shows up as light in Homey, but technically is just a power switch)
-Innr Zigbee lights connected to Homey without being connected to a Hue bridge
-Hue ZIgbee lights being connected to a Hue bridge, then to Homey.

Very strange. Did you already find a solution to stop this unwanted behavior and add the device properly?

1 Like

No solution yet.

Hi, I solved it by removing the battery. And then carefully put it back so that I didn’t activate the button. Then I paired the button. David

1 Like

That didn’t work for me, unfortunately. I still get the error that the pairing was unsuccessful, after which the device does not show up in my Homey at all, but is able to control all my lights. I’ve now discovered that it’s not on/off, but a toggle. So clicking once toggles all devices in all zones that were on to off and vice versa. I’ve also tried to add the device as a generic Zigbee device, resulting in the same behavior.

Super strange.

I have the same behaviour here. Oops something went wrong and turns every T1 switch on/off when pressed, even when it is not paired to anything. When added to Aqara hub everything works. Anyone have any idea?

I had the same issue.
I finally fixed it like this :
1 - Reset the switch (pressing 1 button for 10 sec)
2 - Try to pair again, but not using Aqara app, just using “zigbee” pairing with the switch in pairing mode

Tell me if it worked :wink:

All these methods do not have a universal solution. I wrote about this six months ago. It’s like a lottery that’s hard to win. These methods really work only when you don’t have a bunch of connected Zigbee devices yet. When one of my switches failed due to a battery issue, I took Homey and the switch to work - there I paired them and brought them back home.

It’s strange that Athom and the app developer are aware of this issue but persistently refuse to fix it, insisting that this is how Aqara works and cannot be bypassed. However, these same H1 devices work perfectly fine in HomeAssistant networks, and there is no such problem there.