Unable to log in / run an app using the App sdk

Hey Guys !!
i am trying to use Homey for the first time and i have some problem by following the getting started’s section of the documentation.
I am actually trying to create an app as in the tutorial. So i’ve started with the installation of homey. This happened without any problem.
However the next step which is the login process seems not to work. i ran “homey login”, this command first opens the browser, then I successfully log in but I still get the follwing error message in the console: request to https://api.athom.com/oauth2/token failed, reason: self signed certificate in certificate chain
i skept this step and used the command “homey app create” to create an app and it worked. The next step is to run the command “homey app run”. During the execution I also get an error and i can’t figure out what is going wrong.
“keyword”: “required”,
“dataPath”: “”,
“schemaPath”: “#/required”,
“params”: {
“missingProperty”: “author”
“message”: “should have required property ‘author’”

If anyone has a suggestion to solve this problem i will really appreciate.
Thanks in advance !

The certificate error doesn’t really make sense, unless you’re using a proxy or some sort of antivirus software.

The second error tells you what the solution is: add a property author to the file app.json. For more information, look here.

1 Like

Thank you very much for your feedback.
it had something to do with my network.

So now by running the command “homey app run” i am supposed to choose an active homey by using the arrow keywords. But there is no suggestion.
Any idea ?

And you were able to login in successfully?

yes! everything went fine with the login.