[TUTORIAL] Setting up MQTT on Homey for configuring Home Assistant for dashboard purposes

I think when you just want to have a nice dashboard, and use Homey for the flows, you have more possibilities for tweaking the style using HA Lovelace. I am using it that way, and very happy with it!

Sorry can you explain the aim of using:

Can’t you use the cloud of Homey/Athom to be updated?

Please forgive in case I did not understand the aim of these two components
and in this case a brief explanation would help

thanks a lot

Hi,

I can dectibe in short words the way I installed HA on an QNap NAS.
Further information can be found can be found in the germat thread, too:

You need:

1)Docker service on your Synology

  1. Mosquito Container (search for the docker version named “eclipse-mosquitto:latest”)
    This will be your Mosquitto broker (server) which ist serving all the data interchanged by Homey and HA.
    Please try to secure this with a user/pw. Search for documentation because you need to create the user in the docker-CLI.

  2. HomeAssistant container (search for “homeassistant/home-assistant:latest”)
    Attention: Please search a documentation how to set options for container on synology.
    You shlould create s share where you can put the config files for HA. This share must be assigned to the HA config link while you install the container. If you wan to access via the NAS-IP port 8123, you can set the network settings to “host”. There are several documentations and videos in the web.

  3. If HA in installed an running, create a user in the GUI.
    Then go to “settings/integrations”, install MQTT and set the data of your MQTT brocker (teh instance in NAS container).

  4. Getting Homey data via MQTT:
    Install the Homey app “MQTT Hub”. This app will send all data as entities to MQTT brocker (where HA will retrieve the data while it’s registered as MQTT client).
    The install Homey app “MQTT client” and set your access data to MQTT brocker.

Then you can start a broadcast in MQTT-Hub app settings. This will publish all Homey devices to MQTT broker.
In HA you should seeh the devices/entities now (settings/entities).

Good luck :slight_smile:

This way I’m using HA as Dashboard on an tablet.
I use the lovelace GUI with some custom controls. You wil find many thins to extend HA in the home assistand forum.
For dislaying I use the fully kiosk browser in android. In this browser you can set individual zoom (which ist not possible this way in other android apps/browser).
My Dashboard looks like this:

2 Likes

I didn’t know this was overly complicated. So I have a problem with the (beta) of the home assistant discovery option in the MQTT hub. Home assistant finds everything but for temperature sensors both temperature and humidity are empty.
So I disabled the HA discovery and use the homie/homey-[id] topic for use in HA. But nowhere shows a device… I know this question is more HA related, but that’s just because it seems that HA discovery doesn’t give all the options…
What to do?

Have you enabled the desired devices in the MQTT hub app? Try troubleshooting with MQTT explorer…

Yes I have, and I see that the home assistant discovery mode just doesn’t publish the values.

This is the home assistant thing:


This is the homie convention thing:

Isn’t that weird? There is going something wrong in the app of Harry de Groot.

If you see the values in MQTT explorer, the problem is between your MQTT broker and Home Assistant

See also: https://community.home-assistant.io/t/mqtt-from-homey-to-ha-home-assistant-discovery-doesnt-work-but-a-custom-protocol-doesnt-either/207378/21

Already received a nice review: https://homey.app/nl-nl/app/nl.hdg.mqtt/MQTT-Hub/

I installed MQTT client in HA using the integrations section. But there you can’t set special options.
I uninstalled the Mqtt integration and included the settings in configuration.yaml:

# MQTT Broker
mqtt:
  broker: 192.168.178.237
  port: 1883
  client_id: home-assistant
  username: !secret mqttbroker_user
  password: !secret mqttbroker_password
  discovery: true
  discovery_prefix: homeassistant
  birth_message:
    topic: 'hass/status'
    payload: 'online'
  will_message:
    topic: 'hass/status'
    payload: 'offline'

Without the online/offline messages HA won’t get messages after a restarz of HA service.
With this way of integration I no such problems again.

I would like to achieve the following.

I have HA running well and have a separate tab for my cameras.

Now I have a ring doorbell and I would like to have HA automatically switched to my cameras tab when the doorbell rings. And after a minute back to my ‘’ home ‘’ tab.

I’ve already searched under scenes and automation, but I can’t find it there.

Someone who knows if the above is possible?

Try Fully Kiosk browser with add-on for HA

Btw, this question would be better asked on the HA forum…

Thnx for youre reply, found a solution:

Hi!
Thanks to this topic I’ve managed to create a dashboard which fits my needs! Thanks to everyone who’ve shared their knowledge over here.

Used a Raspberry Pi 3b+ with Home Assistant latest version, iOS Dark Theme, and some custom apps like ‘mini graph card’ , ‘buienradar’ and ‘button-card’ . Every sensor/switch/thermostat is loaded from Homey with MQTT except Sonos, which got added to HA directly so I could use the mediaplayer widget (auto discovered).

2 Likes

THANK YOU THANK THANK YOU!

Ive been at it for XX hours and I´m so bad at network.

But this fixed everything for me!
Thank You!

Hi there, i’ve managed to setup a Raspberry Pi with HA and MQTT broker, and the hub and client on my Homey. Most devices are discovered, except two KAKU devices, but can’t turn on none of them. A discovered lamp switched instantly off when i try to turn it on. The lamp doesn’t react in any way. When i turn a lamp on of of within the homey app, the status in HA changes. So communication is correct i guess.

What am i missing. Devices are discovered, but i can’t use them. Any suggestions?

Problem solved. Issue was the type of communication in the MQTT hub on my Homey.

1 Like

Hi,
I am trying to use home assistant as a dashboard formy homey devices.

1/ Does this tutorial work if i have no synlogy NAS !? I think yes it does ?
2/ i followed all steps but now i am having no devices showing in HASS
About that:
mqtt:
broker: <please_fill_in_the_IP_address_of_your_Synology_NAS>

Is this the ip of home assistant 192.168.1.45 that have to put or the ip of homey ?
Sould i write the ip with the port like 192.168.1.45:8123?

Hope one can help

HASS does not have to run on Synology, a Raspberry Pi or VM will also work fine. How did you install? And have you got a MQTT broker running?

omg somebody (and not anyone i checked some of your posts) is here !

I finally managed to see my homey devices and then they disappeared.

1/ They were showing in home assistant dashboard but i was not able to switch ON but i could see the live state of them (when switch on in homey, light goes on and off goes off)

2/ Now i restarted HA to check if it wrks on restart and now they can come back even after restart MQTT Client and Hub in HOMEY. I restarted HA MOSQUITTO BROCKER they still are grey

For info
My configuration.yaml is like that
image

I have not SSL not SSH

That is my HA->CONF->INTEGRATION->MOSQUITTO SETTING/CONF

And that is my addon setting

Here few logs that seem service not restarting because is 16:10 when i restarted HA

And the settings in your MQTT apps on Homey?

Otherwise, try troubleshooting with MQTT explorer as mentioned a few times in this thread