[TUTORIAL] How to install Telldus Live local control

The excellent Telldus Live app by Bjørnar Amli can access and control Telldus systems via their online API. However, that’s been… spotty at best of late, and luckily it also allows for local control if you have a compatible Telldus unit like the Telldus ZNET lite v2. We just need to generate an access token.
Here’s what you need to do. I’m using a macOS system.

  1. In your router’s interface, check the IP address of the ZNET v2, and consider using a fixed IP for the unit since we’ll be configuring the IP address in the Telldus Live app.
  2. Go to Download | Node.js to download the current macOS version, just click the Apple symbol.
  3. Open the downloaded pkg file and install Node.js with your admin account on the computer.
  4. Open a Terminal (just click the Spotlight icon and search for “Terminal”), type "the following:
sudo npm install npm --global

Enter your password and press enter. Now NPM (Node Package Manager) will be installed.
5. After NPM is installed, enter this command to install Telldus-local-auth:

sudo npm i -g telldus-local-auth
  1. We’re getting close. Now, enter this command to use Telldus-local-auth, and replace with, you know, the IP address of the ZNET v2:
telldus-local-auth IP.OF.YOUR.DEVICE HomeyLocal
  1. A webpage should open in a browser. Log in with your username and password to Telldus Live!, select “One year” and “Auto renew access”, and click on “Authorize”.
  2. Go back to the terminal, and you will see the access token in white letters with black background. Select it in the Terminal and copy it as you would anywhere else on a Mac.
  3. On your Homey Pro, install the Telldus Live app, go to Add new device and select the Telldus Live App. Choose the Telldus Local device here and next, press Connect.
  4. Enter the IP address of the ZNET v2, and paste the Access token you generated in the terminal.
  5. You should now have a Telldus Local device. However, you can’t really do anything with it. No, what you need to do next is add your actual devices. Click on Add device in Homey again, choose the Telldus Live app and this time, choose a Telldus Bulb, Telldus Sensor or Telldus Switch. Click Connect.
  6. Select the Devices you want to add and click Continue. Now, enjoy your locally controlled Telldus devices :slight_smile:

All cred here goes to @balmli for his excellent app and his instructions. I just wanted to flesh them out a bit after I tried this myself.

1 Like

Thank you for laying this out for us idiots! :smile:

However…I get stuck at step 6.

Everything went well (I think) up to that step. I copied your string and replaced the “IP OF YOUR DEVICE” with my ZNET 2 (fixed) IP and get “zsh: no such file or directory:” in Terminal.

What have I done wrong? :face_with_peeking_eye:

EDIT: Disregard the error. I didn’t know that I should remove the brackets around “IP OF YOUR DEVICE”…as I said…idiot. :laughing:

Now I have the Tells Live Local! I would never have managed to do this on my own, so thank you again Johanneso!

1 Like

Great to hear that it helped someone! I’ll clarify the need to remove the brackets :slight_smile:

1 Like

Thanks for a great guide!

I’m using Telldus Live on my Homey Pro today but I think the refresh rate of the sensors are a bit to long, sometimes it can be a couple of hours between refreshes.

So I’m thinking of trying to run in locally instead and have followed the guide in this thread but 'm getting an error at point 7 when the broswer is getting triggered:

404 Not Found

The path ‘/tellduslive/authorize’ was not found.

Traceback (most recent call last): File “/usr/lib/python2.7/site-packages/cherrypy/_cprequest.py”, line 670, in respond File “/usr/lib/python2.7/site-packages/cherrypy/lib/encoding.py”, line 217, in call File “/usr/lib/python2.7/site-packages/cherrypy/_cpdispatch.py”, line 61, in call File “/usr/lib/python2.7/site-packages/web/base/Server.py”, line 230, in call File “/usr/lib/python2.7/site-packages/web/base/Server.py”, line 202, in handle NotFound: (404, “The path ‘/tellduslive/authorize’ was not found.”)

Powered by CherryPy 3.7.0

Anyone else having the same problem?
What can I do to get around this error?

I have tried to run the URL in Chrome, Safari and Firefox with the same results.

Thanks guys!