Switchbot Curtain 3 Homey Pro Sync to Google Home


I’ve connected my Switchbot Curtain 3 devices to my Homey, they work on BLE. I noticed that the response times on an action within Homey take up to 10-15 seconds, which is extremely long at it’s own. But also, when syncing to Google Home, the curtains do not work through Google Assistant, which is kind of a bummer.

Does anyone also have these issues or know a solution? I might have to sent them back otherwise.


Homey’s BLE is a bit slow. They generally work better via a hub, or for best performance use an ESP32 module with my code running on it.

I’m not sure if Google supports curtains yet as I haven’t tried for a long time.

I know that the Hub itself advertises with having direct Google Assistant integration. But, I kind off don’t want to have to buy a Hub because Homey kind off should solve not having to buy a hub for each product.

What is this ESP32 module you are talking about?

You can purchase them from a number of places, including Amazon. It’s basically a system on a chip that can be programmed. However, if you want to avoid hubs then maybe it’s not for you. The advantage over the Switchbot hub is it’s completely local and just act’s as a BLE broker.

1 Like

Hello Jordy,

My blinds @ Homey are available in Ghome; I’d suggest to play with the curtain type.
From Homey settings, make sure the Google Assistant toggle switch is enabled (it gets disabled from time to time).


Google Home:

Also, bluetooth is not the fastest, and can get interfered by 2.4GHz wifi & zigbee (they all use the same frequency band)

To me, Homey is a very nice controller, but it is not a magic box, and has its downsides, like any domotica controller.

1 Like

Thanks for the explanation.

Maybe this would be something to look into, but i’ll do some research.

Thanks anyways!

Hi Peter,

Thanks for your reply. I am not able to locate the “What’s the type” option within the device settings in Homey. Maybe this is a device specific setting? My curtains are added through SwitchBot → Curtains (BLE).


It is indeed specific to each device and I haven’t added an option to change the device class for the BLE blinds. The app sets the class type to ‘curtain’, so maybe that’s the issue. I will incorporate the option to change that in the next update.


Wow, that sounds great!

In the meanwhile, I saw a local store sells the Switchbot Hub Mini (1st edition) for a nice price. I’m going to see if this resolves my issue and if this does anything for the response times.

Thanks anyways for all your quick replies and willingness to help, it’s very helpfull.