Support for Qees RETO shell dimmer?

Hi all, I would really like to have the Qees RETO shell dimmer included in the compatibility list of Homey.
I see there is a Qees plugin dimmer app but not for the dimmer that replaces an wired dimmer.
Its not sold anymore but I have a few of them that work perfectly…
Can anyone help me with this? Im a programming noob:(

Its this unit btw:

Yes I did, awaiting the response if possible.
I did download the gidgub file and changed the unit ID to the correct one for my unit.
I know the unit ID since it is currently on my Vera3 :slight_smile: Will try it tomorrow.
Im a complete noob as said but this might work since other settings should be the same for the plug as the wire dimmer…

The developer tried to include it (there is a beta of the app now in the appstore) but it doesnt get included properly…
It does include but its not shown in the devices menu. When trying again to include the unit, I do need to exclude first so it is coupled…
this is the error I get when loggin zwave activity:

019-01-30T20:03:05.137Z Command[73] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
2019-01-30T20:03:05.435Z Command[73] status: addNode, status: ADD_NODE_STATUS_NODE_FOUND
2019-01-30T20:03:05.774Z Command[73] status: addNode, status: ADD_NODE_STATUS_ADDING_SLAVE
2019-01-30T20:03:09.496Z Command[73] status: addNode, status: ADD_NODE_STATUS_PROTOCOL_DONE
2019-01-30T20:03:09.556Z Command[73] status: addNode, status: ADD_NODE_STATUS_DONE
2019-01-30T20:03:10.051Z Command[73] status: addNode, status: INTERVIEW_CC
2019-01-30T20:03:10.076Z Node[19]: sendData to COMMAND_CLASS_VERSION, params 0x1385
2019-01-30T20:03:10.077Z Command[74] start: sendData
2019-01-30T20:03:10.077Z ProcessSendData[49]: To node: 19 with data: 0x861385 and txOptions: AUTO_ROUTE,ACK,EXPLORE
2019-01-30T20:03:10.114Z Command[74] end: sendData
2019-01-30T20:03:40.077Z Command[73] end: addNode

@Caseda @TedTolboom You guys are good with z-wave, any suggestions on this one?

There is no error in the zwave log, so it probably times out?
What is the distance when including.

About 10cm…

I tried it again a couple of times without luck…
It does find the unit and identifies it but when it shows “command class versies worden opgehaald”, it doesn’t continue and then shows zwave device not found.
After this, the unit is not included but when I try it again, it shows device already included and need to reset it at the device to try again…
I still have no clue why it doesn’t continue (it was previously connected to a Vera3 and worked fine…)