Stop IKEA Fyrtur blinds with remote

I have connected my IKEA Fyrtur roller blinds and my Trådfri open/close remote to Homey using the official IKEA app. I have made flows that let me open and close the blinds with my remote. What I am still missing though, is the possibility to stop my blinds at any given point when they are opening or closing, by clicking the remote again, like you can when the remote is paired directly to the blinds. Anyone know how I can make a flow that does this?

1 Like

This is with the IKEA Trådfri app actually not possible.

3 possibilities come to mind:

  1. Connect the Fyrtur blinds and the Open/Close buttons to the Ikea Hub (if available) and then connect the Fyrtur blinds to Homey using the IKEA Trådfri Gateway app. This app is actually not compatible with the Home Pro (Early 2023)!
  2. Replace the Ikea Open/Close buttons with other ZigBee buttons that have multiple buttons and/or support multiple actions per button (e.g., 2-way, 3-way click and hold). This way you can at least move to multiple, predefined positions. Example of a suitable button: Aqara Opple
  3. Submit a support/feature request to Athom (Link). Athom is the developer of the official IKEA Trådfri app, as you call it.

I found the same issue.
I have Fyrtur/ Praktlysing blinds directly connected to Homey.

My workaround:
I bought an Ikea on/off/dimmer switch (simular housing to the blinds).
It is sold in a kit with a lightbulb or with a 230V socket.

This is a 4-way remote, so having short press and long press functions.
Shortpress up: move up to the next preset flow (25-50-75%)
Shortpress down: move down to the next preset flow (25-50-75%)
Longpress up: full open to 100% position
Longpress down: full closed to 0% position

Variables for full open en closed can be set to XX% ofcourse.
Same for the positions when short pressing.

To finish it I clicked the top cover of the original blinds switch on top of the new dimmer switch.

Solved it using a timer of 15 seconds that sets a variable saying the blind is in motion. Flip the variable upon button press. Then when a button is pressed check if the blind is in motion, if it is → set the position to tag “position”. This tag holds the current position and the card will override the last sent command, stopping the blind.

There is no workaround necessary:
– If you tap Close in the Homey smartphone app, tap Close a 2nd time while the blind is moving and it will stop.

The same works for remote controls and of course with Open:wink:


I also bought the PRAKTLYSING screen but also new with homey. Can you share the flow or anyone please help with a flow to use the remote ?

You only need two flows, like in the screenshot.
No additional flow is needed if you want to stop the movement of the blind. Just click up or down button again, and the blind will stop its movement

For that to work you need to pair the remote directly to the blinds, you can still connect the blinds to Homey.

I use to have mine like that but I like to have the remote connected to Homey so I can set the blinds to only open 80% when I open them with the remote.

No, it actually works without pairing them directly to the blinds

Athom recommends that no device should expose both windowcovering_set and windowcoverings_state at the same time due to user experience concerns (I don’t agree with their argument to be honest). Currently you can only stop (=idle) windowcoverings which expose windowcoverings_state. Some community apps expose both for windowcoverings and you could implement a custom app which does both for the Ikea blinds.

But I get that implementing a custom app is not desirable or feasible for everyone.

Window coverings | Homey Apps SDK

@Doekse is this maybe something which your developers of the Ikea App would be willing to change? Maybe at least as a a setting which adds the windowcovering_state capability only for users who really want it and don’t care about the UX implications. Or alternatively at least an action card to stop the blind?

Is that even possible? When I first added the curtains two years ago I had to reset the remote to be able to pair it with Homey. That means the direct connection between the curtain and remote is reset. I do not use a IKEA Getaway.

Yes if you use the flow card “Set position to _”. Otherwise you are right.

Here is my flow

Sorry, but I don’t understand what you mean.
We’re just talking about stopping the blind at any position, either with the Homey smartphone App (no flow is needed!) or with a remote control, right?
This is all what you need when you want to use a rc:

When you press the Down button, the blind starts to move downwards. When you press the Down button again, the blind stops at the current position.
And of course, the rc isn’t connected to the blind.


Thanks for help, That works! Only one issue…. Everything as described only when I press the second time in the down mode then it won’t stop. In the up mode it works :+1:t2:

Any idea?

Problem is I can not use that flow card. The blind must stop at 90% or it will get damaged. So how do you suggest a flow for that case? The first time the down button is pressed the curtain should start travelling to 90% and when pressed again I can use your suggested flow card to stop it. Problem is it is not possible to know if curtain is moving or not.

If you set the down limit on the blind (refer to the ikea manual to see how you do that) you can set homey to 100% down and it stops at your setting.


Oh my bad. After testing I found that trigger the set position card a second time stops the blind/curtain. Then that is solved.

No, sorry. For me it works without any problems. I have Kadrilj instead of Fyrtur, but I’m sure it doesn’t matter.
Does it work with the smartphone and/or WebApp? Do you have several blinds, or just one?
Add timeline notifications to the flow to determine if a signal was sent from the button or not. Or if the blind has not reacted.

As @Glenn_Seegers already mentioned, I also recommend fixing the lower and, if necessary, the upper position as described in the IKEA instructions. 100 % is the top position and 0 % is the bottom position, even if it’s not the technically maximum top and bottom position of the blind.

Sorry for late reply, didn’t had time to experiment….
Found something out, when the up/down button is connected without flows then the blind react as you mentioned :+1:t2: but it would be nice to have a fix that it will stop at (in my way 44%) when I add the flow(s) to the up/down remote it will only full up or 44% down :frowning:

How is that supposed to work? That’s not really possible.
Have you connected the up/down button directly to the roller blinds? Is that even possible?
Why do you want to stop the blinds at 44 %? Are there certain conditions when the blinds should stop at 44 %? For example, a certain time or a certain brightness?
Please provide more information, I don’t understand your goal.