Sonos - Error when playing soundclips


Suddenly none of my Sonos speakers can play a soundclip with flow/adv. flow. I have tried with the native sound library and with uploaded clips from Soundboard.

I get this message:
Invalid value:[1].clipBehavior

Do you know what could be causing this behavior?

Everything else seems to work just fine with the Sonos app.

Got the same thing after the update. No sound anymore from the internal birds and bells, say … and also from the soundboard app nothing is playing anymore.

for me this feature runs perfectly

please try to restart the sonos app in the homey pro and try again to play a sound a few minutes after restart of the sonos app

I restarted the Sonos app and did the following. Play url is working but play url with volume gives the error. Seems that the Volume value causes the error.

I have also done that. Restarted Homey, restarted Sonos app, restarted the speaker itself. Nothing helps. I have a Homey Pro (2019), don’t know if the issue is only on the older model or not.

sorry I cannot test it on a hp19 - on a hp23 it works fine

Are you running on HP2019 or HP2023?

The HP2023

Same problem when I use Flow-card:




  • Homey (Early 2019)
  • Version: 10.0.1

Maybe it makes sense to create an official support ticket @athom - because this app will be managed by athom

It’s already done, the same day as I posted this topic, but I didn’t know if I was the only one who had the problem.

I have migrated to a HP 2023, same issue persist.

I also got an update from Athom:

"This issue has already been reported by other users. I can’t give any guarantees on when this issue will be found and resolved, but please know that it has been forwarded to our development team and it will be investigated.

We hope to resolve this issue as soon as possible."

Yoy can use the Google Service app to generate an url with TTS.
Then use the Play url sonos flowcard.

Have you already found a solution?

´Play URL´will just play the sound over and over until you stop it yourself, while ´Play sound´ played once and then continued where you left off. I would like to play sound effects and not TTS

Unfortunately no solution yet. They are still looking into it.

If you have a upnp/nas server, you can use the Universal Media Player app to play sounds.

I don’t have the issue of repeating sound when using play url.
When i use it, it will just play the sound and after that continue with its previous playlist or source.

Can you please share the flow? I have tried now with the UMP app, and it works (when using Play URL). But it just loops the soundclip and not going back were it left off.

After I switched out my old Play 5 and upgraded the system to the S2 app, all soundsclips are working again!

Out of nowhere it started working again today.