Somfy Tahoma suddenly returns "bad credentials"

After 15+ attempts, is suddenly accepted the credentials, and everything is working again.

Today my Tahoma box did the same thing.
It would not login and statet ‘bad credentials’
And also after lots of attempts it logged in again.

I had the same problem allthough with Connexoon about 24h ago. The only solution was to remove the app and install it again. Resulting in having to fix a lot of flows. Sad to say this is the third time since i started with Homey 3 months ago.

Same problem here sinds today.
Loggin out at the somfy app(s) did not work.
Restarting the app on homey did not work
Rebooting homey did not work

Is somebody got any other ideas other then reinstalling the app, really don’t want to do all the flows again. :wink:

Running Homey 2.5.2


This morning just try to login and was working again.

For now solved for me

For me also this problem yesterday but after few hours again working. Not big issue untill it happens often. Which starts to be the case. :thinking:

So far, the solution that worked for me every time is to keep inputting the credentials over and over until at some point they are accepted. May take an hour, may take a day, but so far each time there was a moment that credentials were accepted and everything worked again.
Still, since there is no error or warning when the credentials become “bad”, So my only warning I get that something is wrong is when the sun keeps blasting in my face while Homey proudly confirms that the sunscreens have been lowered…

Same problem started here today. Reinstalled the app and the same thing happend again. I can not log in to Tahoma any more from within the app. What is going on? Now I can not control my Somfy devices any more.

just checked, and all is still working here. I would still recommend my solution in the post above…

The Tahoma server was down yesterday for several hours so it might be a side effect of that. As suggested just keep trying.
Maybe try a complete restart of Homey ( leave it powered of for a while) it might have some bad data cached.

Thank you both for the reply. Indeed it was some glitch or error from Tahoma server I guess. As I just tried again and I could login again. Now it is working again luckily.

I noticed the same. Today everything was working again.

Is it impossible to control roller shutters without a internet connection?

From the Tahoma app (the one on your phone) and Homey, yes. The phone app and the homey app communicates with Tahoma via the web interface as Somfy have locked down the direct interface to the box. If you have automations setup in Tahoma then they will continue to run.

Since today I get this response, the app will not work? Ideas?

Restart, does not work, log out will not work

Only I did not try is remove and reinstall. Will try that later but then again I have to repair my flows

Just keep trying to login.
Eventualy you will succeed.
It may take one or two days.

So far thanks for adding LIGHT VAR io in the app. But for now every time I set in a flow to set dimming to 10%, it show in my app dashboard Connexoon LIGHT VAR io - sent intensity- Homey: This action from the application is canceled.

Can you turn on the information log and run the flow again, then change the setting from the Connexoon app. Give it a minute and then send the log.

I just set the information log and run the flow again. But now it gives a error on the command on, what is not in my flow. Only to dimm it to 10%.
The log is send. Hope you can do something with it to fix this bug.
What happens when the lights are off, it give the error on the intensity.

Thanks for the log, it’s very helpful. I can see the problem which is Homey is sending two commands, light on and setIntensity in quick succession.
The hub however can only process one command at a time and that takes a while (in computing terms). If you look at the log you can see the stages the hub goes through of INITIALIZED, NOT_TRANSMITTED, TRANSMITTED, IN_PROGRESS and finally COMPLETED.
But when the app gets a new command it cancels any commands that are in progress for that device so it can send the new one. This is perfect for window covers as you can’t make it go up and down at the same time so the first one has to be aborted in order to send the second one.
This however is not true for lights, so I need to change the rules for how that is handled, to wait for the first command to complete before sending the next one.

I just got the last update for the TaHoma app in homey and after the update, still my lights go on in full 100% accept for the 10% light I have programmed the flow. And in the Connexoon app still gives LIGHT VAR in: The action of the application has been canceled.

Could you send me new logs so I can see if the change I made is working?