Smart Presence is not functioning properly

Hi, i installed the Smart Presence app and added two smartphone devices. But unfortunately it’s not functioning properly, or actualy not at all. The devices are staying online, they won’t go off when i disconnect them from Wifi. Does anybody have had the same experience?

Click the search icon on top of this page and search for smart presence maybe you’ll find some info in all the other topics that are related to this.

Default delay in app settings is 900 seconds. It’s because you will not be noted as not present when your phone is saving battery. In many cases you will need to increase the delay to 1100 or 1200 seconds because of aggressive energy saving functions in the phone.

Thanks i did, apparently Smart Presence doesn’t turn off the device when it goes offline. I think my problem is within the settings. thanks!

Thanks for your tip, i think i need to experiment with the settings.

I got it almost working, but the weird thing is; i have 2 devices installed and the flows are nicely triggered, but when one device connects with the wifi it also triggers the flow of the other device (see screenshot). I already checked the flows, installed the devices again… nothing helps. Does anybody know?

Problem already solved. It turns out there was a fault in a flow.

1 Like

Son what did you do? I have thé same problem…
When spécific user left (device Galaxy pilou)
Then Turn on lamp bedroom

I can’t fill in the tag “who”
In the when fonction. Do you use your device or you select the smart presence app?

Can you give me an exemple please ?

You never can do that in the when section, use the tag in the and part. For example “specific person left” and use the tag there

1 Like

Some fracker made a nice post about “How to use tags” .

Thanks a lot!

Hi. Sorry for another question on this.
Since Homey presence has stopped working I installed this app.
I have set IP’s in router and installed phones as devices etc.
I have this flow. WHEN <-The last household member has left> THEN <set(logic) USERSHOME to No->
Then I have WHEN <-A household member has arrived> THEN <set(logic) USERSHOME to Yes->

It’s not working. With my WIFI turned off on my phone, when I TEST the flows they both trigger the logic no matter the WIFI status. :frowning:

Anyone able to help please.
Thanks.
Darren.

The functionality of the TEST-button in flows is that you start the flow as an event has occured, like “A household member has arrived” or “The last household member has left”. You have no AND-conditions and therefore your THEN-cards will always run when you press test.
There is a default delay of 900 seconds before you will be registered as absent from WiFi. So you have to wait for the delay. For test purpose you can shorten the delay in your phones “device” settings to 120 seconds.
(You will often have to have higher value than 900 seconds because the phones have energy saving functions and only poll the networks from time to time.)