Homey Community Forum

Seperate the input from output - Fibaro Smart Implant

Just out of curiosity, what do you use now? Found something better than Homey? :thinking:

As a matter of fact. But is not for everyone. You love it or you hate it.
And scolds itself Home Assistant.

I have separated input from output with this raw data 57.0x75.0x1.0x2.0x0 but how can I turn on/off the output? If I do I in the device nothing happens.

@Osorkon do the parameters Node-ID,0x75,0x1,0x2,0x0 seperate the inputs from the outputs for both inputs 1 and 2? I still seem to be getting a pulse on output 2 when the contacts close on input 2?

I experience the same issue.
Input 1 got separated from output 1.
Input 2 still switched output 2.
:thinking:

Important update (12 september 2021):

As of Homey v7, the device will now be (by default) included secure (S2 Access) if you use the correct code during pairing, then these commands will not work, the smart implant needs to be un-secure for this to work.
You can still include the device un-secure by using a wrong code during pairing, for example “00000”

@Evgeny_Grin @Peter_Bittner @MrBlue
Actually fibaro made it pretty smart, being able to separate both in and output independently.

Full overview:
Connected in/output 1: (default)
Node-ID, 0x75, 0x01, 0x00, 0x00
Seperated in/output 1:
Node-ID, 0x75, 0x01, 0x02, 0x00

Connected in/output 2: (default)
Node-ID, 0x60, 0x0D, 0x00, 0x06, 0x75, 0x01, 0x00, 0x00
Seperated in/output 2:
Node-ID, 0x60, 0x0D, 0x00, 0x06, 0x75, 0x01, 0x02, 0x00

Also doable in flows with the “Z-Wave → Send raw command” flow card, just leave away the “Node-ID”

5 Likes

Thanks for the help here! Much appreciated.
After executing this command (changed Node-ID to the correct one), it still switches OUT2 with IN2…

Anything else which I can try?
Thanks

woops, seems like fibaro is nice and consistent (not).
I’ve changed the values to now send it to the proper part of the smart implant to disable input from the output:
The change: (has been updated in the “solved” post too)
old::: 0x60, 0x0D, 0x00, 0x02, 0x75, 0x01, 0x02, 0x00
new: 0x60, 0x0D, 0x00, 0x06, 0x75, 0x01, 0x02, 0x00

Tried the new code:
Node,0x60,0x0D,0x00,0x06,0x75,0x01,0x00,0x00

Still same issue :disappointed_relieved:

That’s the default value sir :grin: not the seperate value. Apparently I copied the default one with the example change :joy: so little bit my mistake.
I’ve tested it this time instead of assuming, so 100% sure it works

Finally!!

This finally separated IN2 and OUT2
Node, 0x60, 0x0D, 0x00, 0x06, 0x75, 0x01, 0x02, 0x00

Thank you so much for the help!

Well I’m glad that has been worked out while I’ve been sleeping.
@Caseda could you please explain how you worked this out. I certainly can’t find it in the manual. If Command_Class_Protection is 0x75 it would seem from the manual that 0x60 is Command_Class_Multi_Channel.

Would you mind stepping through each parameter in 0x60, 0x0D, 0x00, 0x06 for input 2.
I understand the input 1 parameters.

Also to reconnect in/out2 your post seems to show the same parameters for both. To reconnect should it be 0x60, 0x0D, 0x00, 0x00 ?

Well actually the work i’ve been doing on the Aeotec doorbell 6 this week made me come up with this.
But you are looking at the wrong spot for locking value.

The multichannel part (the additional values) is just to say to the receiving device that it only needs to go to a certain endpoint, which the fibaro has 7.
It is like putting the message in a box and writing on it that is needs to go to a certain floor.

0x60 COMMAND_CLASS_MULTI_CHANNEL
0x0D MULTI_CHANNEL_CMD_ENCAP
encapsulated to a multichannel endpoint.
0x00 SOURCE_ID
Also endpoint of Homey which main node (0) is good enough
0x06 DESTINATION_ID
Endpoint 6 of the receiving device (not sure why fibaro put it here as output 2 is taken care of by endpoint 2, endpoint 6 is for an external temperature sensor).
0x75 COMMAND_CLASS_PROTECTION
0x01 PROTECTION_SET
0x02 LOCAL_PROTECTION
value 0x00 = unlocked (connected),
value 0x02 = locked (not connected)
0x00 RF_PROTECTION
value 0x00 = unlocked (changeable by Homey),
value 0x01 = locked (not changeable by Homey).

in/output 1’s protection is under endpoint 5, but setting it in the main node is also changing that endpoint and thus the multichannel encapsulation is not needed.

All 7 endpoints:
1: in/output 1
2: in/output 2
3: internal temperature sensor
4-7: external temperature sensor (4x)

And yes, this isn’t in the manual as users normally don’t have to deal with this kind of raw data :stuck_out_tongue_winking_eye:.

2 Likes

Thanks, I’m impressed you worked this out, a big help. So to unlock input 2 from output 2 is the data 0x60, 0x0D, 0x00, 0x00?

Just copy what is in the solution answer, all the parameters are necessary that I have explained (including the right values, which you still have wrong):
Node-ID, 0x60, 0x0D, 0x00, 0x06, 0x75, 0x01, 0x02, 0x00

As I understand it you write 0x60, 0x0D, 0x00, 0x06 to separate in2 for out2. What I was trying to understand is how you reverse that, to connect them back again.

It is al in the explanation, and the solved message, just compare the 2 values, and see the 1 value difference, the second to last value.

This is only like a box with written on it “must go to the 6th floor”, and not the message inside (the rest of the values) to change the connection between the input and output.

Sorry, I’m trying, but the second to last values both seem to read 0x00 for input 2.

1st:: 0x01 0x00 0x00
2nd: 0x00 0x02 0x00
These are the last 3 values of both. (yes 0x00 is 1 value)
See the bold text for the difference :wink:.

Just to be really sure,
first says “0x00” (hexadecimal) which means “0” (in decimal),
second has “0x02” (hexadecimal) which means “2” (in decimal).

OK thanks, I do understand hexadecimal, I used to program microprocessors, although I admit I have forgotten a lot in my senior years. But the values you have referenced seem to me to refer to the values for input 1, not input 2. Unless my assumption re input 2 is wrong. I am assuming that to change the behaviour of of input 2 you use Node Id, 0x60, 0x0D, 0x00, 0x06 to both connect and disconnect, therefore if Node Id, 0x60, 0x0D, 0x00, 0x06 is used to separate the input from the output then one of the parameters would be different to connect them back together.

Thanks for your patience.
Peter