Scene with Fibaro Walli?

Hello,
Anyone managed to start a scene (=flow?) from a Fibaro Walli device(walli dimmer or walli switch or walli double switch ??

If yes, could you put me on the way !? I have tried many things seen in the forum here, but none seem to work)

Thank you

And what did you tried already? It’s tedious to list all the options, even though you may have already tried them.

Set Button 1 scenes and Button 2 scenes (if the Walli Switch is configured as double switch) in the advanced settings to 15.
The flows are self-explanatory, I think.

But, at all my 5 Walli Switches scene activation doesn’t work anymore after an Fibaro app update some month ago. Scene activation worked without any problems before the update. It was not possible to go back to the old app version. Since then I have been writing to the support over and over again. It’s really sad that they can’t get it fixed.
Because the Walli Switch are not used by many other users I guess, I don’t know if I am the only user with this problem or if there are other users with this problem.
So if you have really tried everything and it still doesn’t work, please contact Athom support. :pray:t3:

@fantross
Hi I just submitted a ticket then. Please everybody do the same.

I tried to 15 paramter did not work. I also tried the raw params : 40,1,15;41,1,15; and 40,1,1;41,1,1; and many more.
I could not start nor a a device output nor a flow…

It s like suicide for a smarthome box not to handle Fibaro’s devices fully !!

1 Like

A new test version is available:
image
But I didn’t tried it yet.

EDIT: I tested 3 Walli Switches, 2 in Double Switch operating mode and 1 in Single Switch operating mode.
The Switches in Double Switch operating mode are working perfectly, the Switch in Single Switch operating mode don’t.
Can you confirm this @mattrix?

Yes it s workingwith double switch.
I dont have single switch so cant test.
It s great but i am kind of furious i spent so many hours for not my error.

I’m upset that it worked, was broken by an app update, and then took several months to work again, but only 50 %. :face_with_symbols_over_mouth:

I informed Athom already, that Button scene doesn’t work with Single Switch operating mode devices. I hope the issue will be solved faster than last time.

After re-including my Walli single switch, button scene work also.

Actually walli single switch dont exist. They are walli double switch!
Happy you got it working too.

Yes, I know. And I guess, Fibaro will never release a “real” Walli Single Switch.
I just wanted to let you know in a short form, that button scene works with my Walli Switches, configured as Single Switch operating mode, after re-including. :sweat_smile:

1 Like

Hi Guys,

I’m assing the Walli Switch also. Q1 is wired to a lamp, Q2 is not wired. Althrough I want to use the Walli Switch for opening and closing my curtains by holding upper (for opening) and lower (for closing) button. I set parameter 40 and 41 to the right settings to archive and it works. However the LED ring is only reacting on the fysical outputs and not on the scenes. Any ideas how to lightup the LED ring by activating a scene?

Don’t understand exactly what you want to achieve.
Should the LEDs light up when the button is hold? And after releasing the LEDs should go out again?

Situation 1 - Living room:
The first Fibaro Switch is only used for remote controlling my ‘smart’ devices. Q2 is wired with a ‘switch cable’ however there is no lamp attached at the end of the wire. What I try to achieve is the following:

  • One click on the ‘top button’: lamps on in living room + LED ring ON
  • One click on the ‘bottom button’: lamps off in the living room + LED ring OFF
  • Hold ‘top button’: opening the curtains in the living room
  • Hold ‘bottom button’: closing the curtains in the living room

Situation 2 - Bedroom:
The second Fibaro switch is used for activating a ‘not smart’ wired lamp on Q2 and triggering a smart plug for my ‘nightstand’ lamps.

  • One click on the ‘top button’: lamp (Q2) on + LED ring ON
  • Two clicks on the ‘top button’: lamp (smart plug and not wired to Q1) on + LED ring ON
  • One click on the ‘bottom button’: lamp off + LED ring OFF
  • Two clicks on the ‘bottom button’: lamp (smart plug and not wired to Q1) OFF + LED ring ON
  • Hold ‘top button’: opening the curtains in the bedroom
  • Hold ‘bottom button’: closing the curtains in the bedroom

Both switches are wired as a single switch configuration. I actually don’t know how to configure the Walli Switches in Homey: should it be single, double, 2-way/ 3-way or…? With my current setup the only why to get the LED ring triggerd is by switching the fysical relais of Q1 and/ or Q2 via Homey or the physical buttons. Is there a way to detach the relays and only ussing the switch as remote?

Sorry when my post is unclear. I’am relatively new. Thanks for your help!

The main problem is, that English is not my native language… :wink:

It’s not possible to configure the Walli Switch in Homey as single, double or whatever switch. But it’s possible to change the operating mode between single or double switch operating mode. This has to be done before including process:

Differences between Single and Double Switch operating mode:

Single Switch operating mode
– It does not matter which button is pressed (upper or lower button), the lamp is switched on or off. The lamp must be connected to Q1.
– In the Homey app, the lamp can be turned on or off by simply tapping the device tile.
– In the energy menu only the values for Q1 are shown.
– The entire LED ring lights up when you turn on the Walli Switch.

Double Switch operating mode
– One button is used to switch on/off a lamp connected to Q1.
– The other button is used to switch on/off a lamp connected to Q2.
– Which button should switch Q1 or Q2 can be set in the advanced device settings in the Homey app
– Only the lamp connected to Q1 can be easily turned on/off by simply tapping the device tile. If you want to switch Q2 on or off, you have to go to the tile menu and select output 2.
– In the energy menu the values for Q1 and Q2 are shown.
– The entire LED ring lights up when you turn on the Walli Switch.
– Depending on whether Q1, Q2 or both outputs are switched, the LED ring lights up at the top, bottom or completely.

Single/Double Switch operating mode has nothing to do with 2-way or 3-way wiring. If you want to use them as 2-way or 3-way mode, then the wiring must be adjusted accordingly (please see manual).

Detaching the relays is not possible, but if you want to use the Walli Switch only as remote (and repeater), you only need to wire L and N, that’s all. If you want to use scene activation (one click, double click, tripple click etc.) you have to set parameter 40 and 41 to 15.

The Walli Switch must be configured as Single Switch operating mode.

Flow “Lamps on”
When…
– Top switch - Scene pressed 1x
Then
– Turn on lamp in living room

Flow “Lamps off”
When…
– Bottom switch - Scene pressed 1x
Then
– Turn off lamp in living room

When the lamp is turned on, the LED ring is also turned on automatically. When the lamp is turned off, the LED ring is also turned off automatically.
BUT: If you press the bottom switch first (when the lamp is off), the LED ring will also turn on. So this is hardware related and can’t be changed.

Therefore, my suggestion looks like this:

Flow “Lamps on no. 1”
When…
– Top switch - Scene pressed 1x
And…*
– Lamp is off
Then
– Turn on lamp in living room

Flow “Lamps on no. 2”
When…
– Bottom switch - Scene pressed 1x
And…*
– Lamp is off
Then
– Turn on lamp in living room

Flow “Lamps off no. 1”
When…
– Top switch - Scene pressed 1x
And…
– Lamp is on
Then
– Turn off lamp in living room

Flow “Lamps off no. 2”
When…
– Bottom switch - Scene pressed 1x
And…
– Lamp is on
Then
– Turn off lamp in living room

First I would also change the Walli Switch to Single Switch operating mode and connect the “dump” lamp on Q1.

For this, no flows are needed. But turning on/off the lamp can be done by clicking the top and/or the bottom button.

Flow “Smart plug and smart lamp on”
When…
– Top switch - Scene pressed 2x
And…
– Smart Plug is off
Then
– Turn on smart plug
– Turn on smart lamp (maybe with 1 sec delay)
– LED Color when turned off (Color: whatever)

Flow “Smart plug and smart lamp off”
When…
– Bottom switch - Scene pressed 2x
And…
– Smart Plug is on
Then
– Turn off smart plug
– Turn off smart lamp (maybe with 1 sec delay)
– LED Color when turned off (Color: Off)

Please try it, if it will work. But be aware off, pressing the Walli Switch buttons 1x, the LED ring will turn on if it was turned off and wise versa.

Flow “Open curtains”
When…
– Top switch - held down
Then…
– Set the position to 100 %

Flow “Close curtains”
When…
– Bottom switch - held down
Then…
– Set the position to 0 %

Hi Fantross,

English is also not my native language, op zijn nederlands gaat het een stuk makkelijker :wink:

Anyway I really appreciate the time and effort you put in this post! If i know where your house lives, I had send some beer :wink:

I strubbeling the complete morning to get all my Fibaro working but getting many errors. All switches are not responding. When I try to switch them in Homey I get the error: ‘transmit complete no acknowledge’ or ‘network failed’. I already reboot Homey and reset the complete z.wave network without any success. I disconnect all devices from the wall and put them next to Homey to add them again. I’am living in a smart apartment so that should not be the case.

I hope that I can fix this soon and then I will work on your brilliant post.

BTW: I had the manual of Fibaro. Changing from double to single is different to change.

But not for me, I’m from Germany… :joy:

It looks like that you have connection problems. Homey does not have a large Z-Wave signal range, so it makes sense to install/mount the first actuators/repeaters near Homey after including them in close proximity to Homey. And then going on.
The Z-Wave network is a self-healing network. This means that the devices optimize their route independently. However, this can take some time. Here is a support article from Athom, Link.

Different? Or do you mean difficult?