Activate flows using Fibaro Switch 2 scene activation


I have a few Fibaro double switch 2 (FGS 223) installed in my house. They connect fine to Homey but I can’t get them to activate flows when I double or triple press (2x press/ 3x press) the button.

My setup so fare:
Device added to Homey using Fibaro app.
Device settings:

  • Switch type: Momentary switch (my physical switch is momentary)
  • No associations other than default.
  • Not sure what to set here. Manual says parameter 28 and 29 should be set. What raw value should I use?

A flow created using this:

  • When: Left switch Scene (S1) Pressed/switched 2x.
  • Then: Sen push notification

Testing the flow works fine using the test button in Homey. But nothing happens when I double press the switch.

Anyone else having the same issue and resolved it? Any help is very much appreciated!

1 Like

Can u show us a screenshot of the settings of the switch?

See (merged) screenshots below. I did not include associations since default settings are used there.


Appreciate you taking a look in this.

Looking at the manual, the scenes are disabled by default.

Maybe try enable the scenes by writing raw values on parameters 28 and/or 29.
In your case for S1 double click, you need to write value 2 on parameter 28 (of size 1 byte according with the manual).

So you should write 28,1,2 (parameter number,size,value) Then hit Save Settings.

Not sure which fibaro version you are running (stable or beta), but both parameters (28 and 29) should automatically be set during pairing by homey to a value of 15 (link to code).

15, is all values combined = all scenes enabled.
I use it myself everyday (now with the beta app, but also stable before there was beta).
Though I do use only single press, few weeks ago I tried it into the debug log and it showed 2x press just fine.
(It can of course happen that the parameter(s) have not been set right during pairing).
I will test the multiple press again (hopefully this evening), but I think that still works for me.

If you want to try out the raw configuration (to “resend” it), you can add 28,1,15;29,1,15

1 Like

Update on this issue,
it is indeed a mistake in the driver of the v2.* update of fibaro app.

The “everyday” usage of mine is the single switch 2 (not the double switch 2) which is a little bit different in the driver (not sure why, as they can be pretty much the same).
Found the issue and send in the fix to athom (alpha branch) now it is up to athom to incorporate the fix in alpha app and probably really soon (if not immediately) in the beta app

1 Like

Thanks for suggestions and looking in to this. I finally got around to test setting the raw configuration to 28,1,15;29,1,15 and it worked. Now I can activate flows using double and tripple press of the button.

However, I realized there is another, related issue. Doing an double or tripple press always include a starting single press. This means that the load (lamp) connected to Q1 toggles when pressing the button. Doing a double or tripple press makes the lamp toggle ones.

Anyone else experiencing the same issue? Or maybe have a workaround? I guess this is a Fibaro related issue, since this type of logic is happening in the unit itself, rather than Homey, I guess?

Edit: I am using version v1.5.18 of the Fibaro App. I will try out the beta version to see if there is a different behavior.

Correct, this behaviour is from the module itself, it will always toggle the corresponding output, and sadly this behaviour can not be changed by parameters (settings).

you can “work around” it by switching it off again with a/the 2x press flow (or any other related), but that does mean it will turn on for a second or two.

I can also confirm that this is from the module itself. It behaves the same with Fibaro HC2.

Continuing the discussion from Activate flows using Fibaro Switch 2 scene activation:

I have the same problem. I have set the parameters as told here, but I can’t still get it work.
I have the Fibaro Double switch 2.
The switch is in the bathroom and I want to put the ventilator at higher speed, which is prepared for that.
Testing the flow, it says it’s working, but as I pull the switch 2 times shortly, nothing happends.
What did I do wrong? I appreciate any help!

Picture of the flow I made.

Is this still the same anno 2021? I’m using a Double Switch 2 in scenes with no connected outputs. Working perfect but it would be even better if I could control the state of the switch only with a flow…

unless they changed the firmware of the switch 2, nothing will change, it isn’t something we can change, only Fibaro (and i believe they didn’t change this in an firmware update)