Roborock s5 handshake timeout

I am trying to connect my Roborock S5 vacuum with Homey. I retrieved the roborock token by installing an older version of the mihome app. I am also using the correct ip adres. Unfortunately Homey says ‘could not connect to device, handshake timeout’. Anyone know how to solve this issue?


I did exactly that yesterday and it worked. Ran into another problem soon after, if you get your problem let me know :slight_smile:
I followed the following process for the token:

  1. First had the latest MiHome app installed on Adriod Device 1 and working for about 4 weeks
  2. Then asked user file from MiHome like someone suggested. The file did not contain the token.
  3. The modified MiHome app did not want to install on Andriod Devices 1 and 2 but the 3rd worked and I got the token (as I assume you did).
  4. Inserted the token on Homey on 1st device and it connected. MiHome app on Device 1 also still working.
  5. IP address i got from my router where it is also set to keep the current IP and not auto.

Maybe something is of use for you.

Delete the old log file. Install the old app again and get the token again. Mine changed once.

Same problem here, tried all the steps. Token should be right, via iobroker i can get a connection.
Tried from different devices Android and iOS.

One Xiaomi 1st. Gen and one S50 Roborock.

Any idea?

did you find a solution to this? I have the same issue